water transparency

Started by cocakola, August 06, 2008, 09:24:42 pm

Previous topic - Next topic

cocakola

I have gotten really frustrated trying to figure out how to get the water transparent, so i can see through it!  I have the Waterworks plugin and the SO Opacity, but they don't seem to help.  Are there specific settings i need to set or something?  Thanks

buzzzzz1

Hi,

Assuming you are using v9.43? Click on the Water Icon on the left, the water settings window should appear. The transparency setting are in the sub-surface tab.

Have Fun!
XFX 750i SLI  nFORCE Mobo
Intel Core2 Duo E8400 3.00 GHz Wolfdale
8 Gig Corsair DDR2 6400
Nvidia GForce 9600 GSO 768 MB
XP Pro 64 bit OS

cocakola

August 07, 2008, 03:02:39 pm #2 Last Edit: August 07, 2008, 03:09:04 pm by cocakola
I have tried using and adjusting those settings but the water transparency never changes. 

Here is what i will get:
http://img233.imageshack.us/img233/2184/79772000tr3.png
http://img143.imageshack.us/img143/4981/44906256lk4.png

I would like to see through the water.  Its just confusing.  And Yes, i am using 9.43.  Thanks

PG

Well you've got transparency there. You're not going to be able to see through the water plane very far unless the water is very very shallow. Turning up the Transparency Dist. setting will allow you to see further though.
Figured out how to do clicky signatures

cocakola

August 07, 2008, 07:25:52 pm #4 Last Edit: August 07, 2008, 07:37:37 pm by cocakola
Ok, i have set the water level to 1, and have raised the terrain slightly so it will be like a shore.  And this is the result. 
I do see a little transparency, but its not much.  I would like to have the water like this: http://sanby.deviantart.com/art/terragen-Beach-1663248 .  The water looks completely different than mine.  Thanks for the help.

jo

Have you tried using the presets? They should be a quick and easy way of showing you different effects.

I see a lot of transparency, but obviously you aren't getting the depth effect kicking in. Part of your problem may be that the water isn't very deep. It looks to me like the water might be filling a very shallow area with a pretty constant depth, is that right? Try reducing the Greatest Depth setting ( might be called Transparency Dist. or something in the Windows version ). If you set it to just a little bit less than the depth of your water in the area you want to see more intense water colour then you should get a much stronger depth effect. The readout at the bottom of the View & Sculpt window will show you the depth of the water when you move the mouse over it, it's the number which comes after the "D".

The brightness of your sky and its reflection isn't really helping, it's overwhelming the water so it would be hard to see much effect in the distance anyway, if that's what you're after.

Regards,

Jo

cocakola

August 08, 2008, 12:01:41 pm #6 Last Edit: August 08, 2008, 12:07:54 pm by cocakola
Ok, this time i got more of what i wanted.  Here it is:

I just need to adjust the water levels a little more so i can get more transparency.  Thanks for the help.  Also, is there any way to blur the part between the water and terrain so it looks more natural?  Or does that have to be done in photoshop?

jo

Hi,

If you're happy with the water level, to increase the amount of transparency you can increase the Transparency Dist. setting. That will move the point where the "solid" ( or diffuse ) water colour takes over further offshore.

You will need to smooth the transitions yourself. TG v0.9s terrain is a faceted heightfield which just happens to be make fairly smooth looking by the surface texturing. The edge of the water shows the true intersection with the terrain though, so it can look angular rather than smooth.

Regards,

Jo