Getting Error When Trying to Open "COMDLG32.OX is missing"

Started by dallas59, August 16, 2008, 05:47:44 am

Previous topic - Next topic

dallas59

Hi. I have a registered paid version of Terragen 9.43 and today I couldn't open the application. I get a an error message telling me that

"COMDLG32.OX'or one of its dependencies not correctly registered: a file is missing or invalid"

Everything was fine yesterday.

What can I do? >:(

I'm running XP, P4, 2 gigs of ram and my machine is virus and trojan free.

dallas59

Well I did a search and found a fix.

http://windowsxp.mvps.org/comdlg32.htm

Outdated or missing comdlg32.ocx runtime library is causing this error. Here is a copy of comdlg32.ocx (~60 Kb Zip). Download the file to the Desktop and extract the comdlg32.ocx to your the Windows\System32 folder.

Note: If you already have a copy of comdlg32.ocx, backup the existing file to a different folder and delete it from System32 folder.

    1. Download comdlg32.zip and save to Desktop.

    2. Unzip the file using WinZip or any other utility.

    3. Extract comdlg32.ocx to Windows\System32 folder.

    4. Type the following command from Start, Run dialog:

    regsvr32  %Systemroot%\System32\comdlg32.ocx

    You should see the following message:

    DllRegisterServer in C:\WINDOWS\System32\comdlg32.ocx succeeded.

    Comdlg32.ocx file information

    CompanyName    Microsoft Corporation
    FileDescription    CMDialog ActiveX Control
    DLL FileVersion    6.00.8877
    InternalName    CMDIALOG
    LegalCopyright    Copyright © 1987-2000 Microsoft Corp.
    OriginalFilename    COMDLG32.OCX
    ProductName    CMDIALOG
    ProductVersion    6.00.8877 Comments: May 26, 2000

After following the instructions Terregan opened up. :D

Oshyan

Glad to hear it. Something must have changed on your system since the last time you successfully ran Terragen. Did you install or uninstall any other applications? You could also have tried System Restore to the last time TG worked. But it's good that you found a less drastic solution.

- Oshyan