Put a memory cap!

Started by dark_Wizzie, September 30, 2008, 08:56:03 pm

Previous topic - Next topic

dark_Wizzie

September 30, 2008, 08:56:03 pm Last Edit: September 30, 2008, 09:08:59 pm by dark_Wizzie
How do I cap the max ram used to be 2 gigs? My ram can not handle over 2gigs.
also the task manager says cpu is barley working.

Oshyan

As a 32 bit application TG2 cannot actually use more than 2GB of memory anyway. However if you do need to adjust memory use there is one option. Although you cannot set an overall maximum for memory use in TG2, you can at least affect a large part of the memory use by setting the "Size of Subdiv cache" setting in the Advanced tab of your renderer node. The cache size is a total which will be divided among the number of render threads in use. There is a minimum size of 50MB per thread, so if you have 2 threads, the cache will need to be 100MB or larger. Smaller caches may result in sub-optimal performance, especially on complex scenes. However if you have memory constraints, I suggest limiting threads to 2 at most, and using perhaps 100MB *per thread* cache size. Setting the cache size will not limit overall memory use, however

This brings us to the second part of your question which is that your CPU does not seem to be fully utilized. It is important at this point to know the full specifications of your computer, especially your CPU and operating system, and also to report how many "Processor Cores" TG2 finds when it starts up. This will be shown in the Splash Screen. It is possible either that A: it is not detecting all the CPU's/cores you have and thus not utilizing them all or B: you are using a high-end system with a large number of cores and running into efficiency limitations which TG2 has in utilizing more than 4 cores. Your specific system configuration will have a large effect on how you need to proceed.

- Oshyan

dark_Wizzie

4 cores found 16600 2.4ghz os xp service pack 3

Oshyan

And how much RAM do you have? As I said before TG2 can only ever use up to 2GB of memory in total (under a 32 bit OS, which is true in your case). So there should be no need to limit it to that amount manually if you see that as the source of a problem. Perhaps a better question is why did you want to limit it? What behavior or issues have you seen which you believe are memory-related?

- Oshyan

dark_Wizzie

None, I just found out the compputer is using 2.2 gigs of ram.

dark_Wizzie

problem is, i am getting very, very,very unclear images! It took my good computer 4 hours to come up with part of a fuzzy picture. I am frustrated i can't make a single image without such problems in terragen 1 or 2.[img=http://img220.imageshack.us/img220/1696/72039714kb6.th.png][img=http://img220.imageshack.us/images/thpix.gif]

Oshyan

It's difficult to see what's going on from that small picture. However considering how simple your scene looks, and the long render time, I am guessing that you have very high render settings. There is no other normal reason I can think of for that kind of render time on a scene like that. If you can either provide a better screenshot, or the .tgd, we may be able to help more.

- Oshyan