Adjusting Camera Crash

Started by RArcher, January 16, 2007, 12:36:42 pm

Previous topic - Next topic

RArcher

January 16, 2007, 12:36:42 pm Last Edit: January 16, 2007, 02:59:59 pm by RArcher
Adjusting the camera with the attached file causes a program shutdown.  Disabling the image map shader fixes the problem, but when it is enabled again the problem returns.

edit: added the image map texture

Njen

I just tried your file and it works fine with me, but then again, you didn't supply the image file so I was unable to test it with your exact conditions.

Will

Does attaching the image map node cuase a loop some where, that could be it.


Regards,

Will
The world is round... so you have to use spherical projection.

RArcher

Sorry about that, I assumed it bundled the image with the tgd file.  I edited the original post adding the image.  Thanks for taking a look.

Njen

Ok, I could reproduce the crash.

I am guessing that it has something to do with the Projection Type. With it's current selection of Through Camera, it crashes. But if I change the projection to any other type, then it seems ok.

Maybe the crash has something to do with the fact that it's trying to project through the camera, but at the same time the camera is moving, so it doesn't know what to do and gives up, but that's just a guess.

To fix the problem for now, I suggest you create a second camera and project through that, or just use a different type of projection.

Will

That would explain it. Good work team.

Regards,

Will
The world is round... so you have to use spherical projection.

Will

I also just had the problum and it seems for me it only has to do with displacement setting in the image map node.

regards,

Will
The world is round... so you have to use spherical projection.

Oshyan

Moving the camera that an Image Map shader set to Through Camera projection is referencing should not cause problems. I've done this quite a bit myself and haven't had such crashes. It would appear there is indeed something about this scene that causes a crash in this case though - it may well be related to the displacement. We'll add it to the crash list. ;D

- Oshyan

richardcasaubon

I had the same problem. I was using two image map shader. One for the texture and one for displacement using a bump of my texture. The first clic the move tha camera will have T2 close instantly.
Richard
Richard

Blackheart6004

January 20, 2007, 10:38:40 pm #9 Last Edit: January 20, 2007, 10:43:46 pm by Blackheart6004
Quote from: richardcasaubon on January 20, 2007, 11:19:02 am
I had the same problem. I was using two image map shader. One for the texture and one for displacement using a bump of my texture. The first clic the move tha camera will have T2 close instantly.
Richard


Samething happened to me.

I've added 2 image map shaders to my scene (one for the surface and one for the displacement), one click on the camera in the preview windows and TG2 crashes.

Just now I had this problem.
My DeviantArt Profile - http://blackheart6004.deviantart.com/

bakara

I had the same problem today, using an image shader in the fractal breakup part of a surface layer.