Beta Problems

Started by j meyer, November 12, 2008, 12:25:50 pm

Previous topic - Next topic

j meyer

Hi,
i'm getting some problems with rocks especially with rock populations.
Missing faces as in the attached pic is one.Another one is that increasing
and decreasing the number of faces seems to have no effect or very little
for populations and smooth normals doesn't work either,although once
there was a single member of a pop that got smoothed.
Furthermore TG occasionally creates render nodes when choosing a rock
population or at saving the tgd (i've attached a bak file also for comparison).
Displacement isn't working correctly also.

Another little thing is that from time to time typing 0.75 into a slot on the
color adjust shader results in 50.7,tried it more than once.
And on one occasion the col adjust sh floater disappeared behind the main
window,but i could not reproduce that as of now.

One more thing:connecting the last shader of a node group to a sphere via
assign shader caused a broken/disconnected connection in that node group.
This should be replicatable,tested it a few times (also in TP5).


That's it for now,J.

System specs:Vista 32 Home Premium,Intel Quad 6600
                    NVidia 8500GT,2 GB ram.

Matt

Yes, there is still a rendering problem with rendering rock populations. I wasn't aware of some of the other issues - I will take a look.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

j meyer

Thanks Matt.
Just found something else:started TG,then set the camera to 0/1000/0 and
rotation to -90/0/0,then rmb-click on Base colours -> other surface shader ->
surface layer,that caused the surface layer floater to open behind the main
window.It was reproducable for me.( closed the app and restarted before
trying again)
J.

dandelO

I've had a few of the disappearing windows, it takes 3 clicks to restore them to the top. Sometimes on the render window and sometimes on the shader settings windows too. I can't replicate the surface layer thing you describe above on my computer though.

I've kind of given up on using rocks, shortly after the initial fun of being able to move them about wore off, because you still can't add any displacement to them without the faces 'shattering' at the edges. I didn't report it as it's always been this way and I just assumed it hadn't been solved yet. Back to fake stones for everything for the meantime then...

Mohawk20

I did get smoothed normals in a rock population, as seen here:
Howgh!

rcallicotte

@Mohawk - How many changes to the rock did you need to do to get this beautiful gem?
So this is Disney World.  Can we live here?

Mohawk20

Not much, though it does have a lot of faces (64 to be exact) and a diameter of 20, and therefore 10 units from the ground, because the rock object's pivot is in it's center.

But the amount of faces didn't seem to affect render times that much, and neither did the smoothed normals...
Howgh!

j meyer

I'm just reporting.

dandelO:it's possible with 1 click on the whateveryamightcallit that's
appearing on the taskbar,at least for me it was.

j meyer

In the meantime i've tested the Painted Shader (which is a really great
addition btw) with a tablet and there seems to be a little lag reactionwise
and it's a bit jerky.Is that how it's supposed to be for now,since tablets
are not supported yet as far as i know?
Moreover the built in Vista tablet feature(sorry don't know the correct english term)
seems to interfere somehow.Occasionally a silvergrey ring showed up and then a
context menue opened.Also the little pen icon appeared in the parameter floater
of the Painted Shader and elsewhere.Until now i've never noticed that behaviour in
any other application i use.
J.

Tibbar

I was sick of seeing the spinning circle icon as well when using my tablet in Vista. So I turned off the feature.

In Vista's Programs and Features, click the the "Turn Windows features on or off" link. Uncheck "Tablet PC Optional Components".

Disable any remaining settings in the Tablet PC Settings of the Control Panel. Especially in Pen and Input Devices, you can remove visual feedback for single-tap, double-tap, etc. As well as Flicks.

jo

Hi,

Tablets are not supported specifically at all, so I have no idea how they might interact with TG2. However we do intend to add support for tablets, especially for the painted shader, in the future. I doubt it'll be before the final release though.

Regards,

Jo

j meyer

Knaht uoy rabbiT.

Noticed that i had forgotten to test one more thing,so here goes:
switched from pen mode to mouse mode in the tablet's settings
no lag,no jerking and no interference from the tablet pc feature.
Of course it's of almost no use then,because it's somewhat
like drawing on a stamp with a felt pen.
From my point of view the tablet/pen should work like normal just
without pressure sensitivity and such in an app that doesn't support
tablets,but i could be wrong of course.

Matt

Quote from: j meyer on November 20, 2008, 04:03:33 pm
From my point of view the tablet/pen should work like normal just
without pressure sensitivity and such in an app that doesn't support
tablets,but i could be wrong of course.


That is how it should be. We don't (currently) detect the pressure or anything else that is not on a normal mouse, so there shouldn't be any difference in the painting whether you switch to tablet or pen mode. If there is, can you be more specific about the differences? Is it just the lag/jerkiness and GUI glitches, or do things really appear to be different or wrong in how the paint is applied?

Matt
Just because milk is white doesn't mean that clouds are made of milk.

j meyer

I think i'll have to do some more tests before i can answer appropriately.

j meyer

First let me say that i couldn't find anything else,just the lag/jerk thing and
the interference,no problems in how the paint is applied.But i've not tried
every possible combination of modes,camera angles,brush sizes and so on,
of course.
Switching off the Tablet PC i got rid of the above mentioned pen icon appearing.
And just like Tibbar said unchecking the features in the pen and input settings
stopped the lag/jerk.Right click,for instance,is executed when you hold the pen
in place for a moment,which makes the context menue open up.So it's like the
vista pen settings seem to override the settings of the tablet/pen itself,at least
in some applications.
I've tested it with TG2 Beta,v0.9x,Bryce5 and XSI Foundation.XSI is not affected
at all ,in Bryce and v0.9x the lag/jerk is hardly noticeable,it's more like a subtle
fade in of the stroke,i had to try it twice before i was sure that there is a difference.
In TG2 Beta the effect is much stronger,see example below (the strokes start is
on the upper end and they were rather slow;it might be possible that stroke speed
contributes occasionally,because there is some feature in vista's pen settings that
depends on movement direction and/or speed,not sure though).
So the award goes to vista here,i guess.
No idea why XSI is not affected or why it's stronger in TG2,that's beyond my horizon.

J.