Half covered Fake Stones

Started by mr-miley, January 18, 2007, 11:04:49 am

Previous topic - Next topic

mr-miley

January 18, 2007, 11:04:49 am Last Edit: January 18, 2007, 11:49:33 am by mr-miley
Right, thats it, this is driving me insane!!  ??? I am trying to add a fake stone shader to my scene. Simple enough. I can get them to be where I want them to be etc, but whenever I render the scene, some of the stones are half (or in some cases totally covered with the Base Colours shader. I did have a few more surface layers between Base Colours and the stones, and which ever one is next to the stones in the list is what half covers the stones. Attached is a crop render (I blew it up cause it was quite small) a screen shot of my shader nodes and the scene file. If anyone can help.... please



Crop Render




node screenshot


EDIT:- Damn, forgot to include the heightfield
see below


Ta

Miles
I love the smell of caffine in the morning

Volker Harun

Hi,

as I am rendering a HiRes-Picture, I did not have a look at the .tgd you uploaded.

I had the same problem until Turning the 'Coverage' inside the distribution-shade to '1'.
Adding a blender to the distribution-shader would give extremly bad results, too.

V. Haroon

mr-miley

Voulge

Thanks for the reply. I have got the coverage set to 1 in my distribution shader. I have even downloaded a couple of example files using the fake stone shader from the forums, just to see if I was doing something really daft (not unheard of) and my settings are the same (appart from scales etc)  ???
I love the smell of caffine in the morning

littlecannon

Have you tried adding a compute terrain in the terrain tab , then adding the Fake Stone Shader also in the Terrain Tab, rather than in the Shaders Tab... That's what I did for my Canyon and I could colour the stones as I wanted... just another thing to try.

Simon.
I just need to tweak that texture a bit more...

Volker Harun

January 18, 2007, 01:32:15 pm #4 Last Edit: January 18, 2007, 01:54:51 pm by Voulge
Hi,

turn off the "Blend as stone density" at the bottom of the 'fake-stones-shader'.

And turn the pancake-effect to '2' that should some!

MeltingIce

Get rid of your distribution shader and use a surface shader instead.  Set the color of the surface shader to white and use its slope and altitude restrictions instead.

MeltingIce Network | Wii Number: 3881 9574 8304 0277

Lucio

I've the same kind of problem.. a distribution shader (even a surface layer) applied as a blendshader to fake stones gives strange results

mr-miley

Thanks for all your ideas... none of them have worked, mind you. MeltingIce, I may well be being a bit stupid (nothing new there) but I can't find slope and altitude restrictions in any surface shaders, care to elaborate?
I love the smell of caffine in the morning

Volker Harun

Well,

I marked the tabs for distribution on the attached image.

V.Haroon

Volker Harun

Another problem that occurs is the following.

Please have a look at the attached picture - it shows the render in progress (I am rendering cropped to reduce data-loss on crashes)

The stones right from yellow marks are broken - or are sitting on top of each other (which is somehow nice).

You can get the false colouring when looking in detail. I minimized the problem here due to colouring the surface below with the same texture as the stones.

Regards,
V.Haroon

rcallicotte

Good job, Voulge.  Believable rocks, I think.
So this is Disney World.  Can we live here?