Clouds with a difference

Started by oggyb, January 19, 2007, 09:03:57 am

Previous topic - Next topic

oggyb

I call this setting "spasticity".

Why does it happen?

Will

Are thoughs clouds on the bottom?

Regards,

Will
The world is round... so you have to use spherical projection.

oggyb


Will

weird, ok im looking into the .tgd now

Regards,

Will
The world is round... so you have to use spherical projection.

Will

I think it has to do with how your cloud depth is larger then the altitude.

Regards,

Will
The world is round... so you have to use spherical projection.

oggyb

I always assumed, from playing with settings the altitude was at the centre of the depth?  But then, does that mean it's at the top?

M.

Will

Well I just think that what is happening is that the depth is greater then the altidute causeing its to go below the terrian cuasing it to look like that.

Regards,

Will
The world is round... so you have to use spherical projection.

Njen

Cloud depth is at the top of the clouds. So if you had an altitude of 1000m, and a depth of 500m, then the lowest parts of your clouds will be 500m above the surface.

oggyb


swiftstream

January 19, 2007, 04:13:37 pm #9 Last Edit: January 19, 2007, 04:17:06 pm by swiftstream
This is a known bug with the acceleration cache. Turn off the acceleration cache in the quality tab for the cloud layer and it will go away.

Edit: oggyb, you were correct about the cloud layer. You set the altitude of the middle of the clouds, vertically; the bottom of the cloud layer is at (altitude-depth/2), and the top is at (altitude+depth/2). Taking njen's example, the lowest parts of your cloud will actually be at 750m, and the highest parts at 1250m.

Will

swiftstream I tryed that why I played around with the file for him but it was already off so I think its a cloud density issue.

Regards,

Will
The world is round... so you have to use spherical projection.

swiftstream

January 19, 2007, 04:17:42 pm #11 Last Edit: January 19, 2007, 04:42:17 pm by swiftstream
When I downloaded it the acceleration cache was turned on, and when I turned it off it rendered just fine.

Edit: I've attached (the beginning of) the render with the acceleration cache turned off. As can be clearly seen, the clouds are not longer "spastic."

Here's the file diff, to show that that is indeed the only change I made:

C:\Documents and Settings\root\My Documents\Terragen>diff Spasticity.tgd Spastic
ity2.tgd
13,15c13,15
<       gui_network_view_position = "-126.19 299.839 0"
<       gui_network_view_size = "554 301 0"
<       gui_network_view_zoom = "0.204826"
---
>       gui_network_view_position = "-158.121 220.803 0"
>       gui_network_view_size = "554 0 0"
>       gui_network_view_zoom = "0.189728"
527c527
<               acceleration_cache = "1"
---
>               acceleration_cache = "0"

C:\Documents and Settings\root\My Documents\Terragen>

Njen

Quote from: swiftstream on January 19, 2007, 04:13:37 pm
This is a known bug with the acceleration cache. Turn off the acceleration cache in the quality tab for the cloud layer and it will go away.

Edit: oggyb, you were correct about the cloud layer. You set the altitude of the middle of the clouds, vertically; the bottom of the cloud layer is at (altitude-depth/2), and the top is at (altitude+depth/2). Taking njen's example, the lowest parts of your cloud will actually be at 750m, and the highest parts at 1250m.


opps, yeah I was wrong there :)

oggyb

So I was right about the altitude, but there were two problems I was addressing.  The first was the fact that the clouds consisted mainly of ridiculous blobs, and the second was that the clouds were rendering on the ground as well as in the atmosphere, but separately.  I.e. there's a bit of horizon where the clouds should theoretically cover up.

The first bit's been sorted by swiftstream, and thanks for that.  But what about the other bit?

M.

Will

I think the secound does have to do with your altitude and depth settings try raising your altitude more. The first one I think could be addresed by setting your cloud edge shapness to like 2 and not 50.

Regards,

Will
The world is round... so you have to use spherical projection.