errors in terragen 2 during rendering

Started by mmatthe8667, February 15, 2009, 12:55:48 pm

Previous topic - Next topic

mmatthe8667

an unknown error occurred in TraceRay

Get that error 4 times

And get this error


An unknown error occurred in trBucketRender::RenderMore() Ray-traced pass

And this one

an unknown error occurred while a render thread was rendering a bucket

Any help as what would be causing this?

My machine specs are

AMD dual core 3.2 ghz
4 gigs of ram
8800 GTS 512MB g92 video card

mmatthe8667

Oshyan

We need to know a lot more about your scene to understand why these errors may be occurring. There are 2 major possibilities, a memory issue due to a very complex scene, or an error in rendering reflections. If you can describe your scene more fully, or better yet provide a partially rendered screenshot, that would be helpful. It would also be good to know what operating system you are using and whether it is 32 or 64 bit.

- Oshyan

mmatthe8667

Scene of multiple clouds that found a tgc for online.  I wanted to do a render of it with mountains coming up out of them.  No water..just clouds and mountains.  I am running windows 7 beta 64bit.  I have reduced the number of threads down to 1 min and up to 4.  400 megs of memory is being used.
I was able to render a 800x600 image but to do like a 1900x1200 I get errors.  Oh the quality setting on the render is .75 and all the other stuff in it was left as default.

mmatthe8667

Oshyan

That's surprising given the details you've provided. With 4GB of RAM and a 64 bit OS you should not have any memory issues until you have a much more complex scene. As a test, can you try setting *max threads* to 0?

- Oshyan

mmatthe8667

What does setting the max to 0 do?

mmatthe8667

Oshyan

It sort of turns off the multithreading, which in itself can cause some issues due to its added complexity.

- Oshyan

mmatthe8667

February 18, 2009, 10:25:39 am #6 Last Edit: February 18, 2009, 10:28:53 am by mmatthe8667
Whats weird is had it set as 1 min to max of 16 threads with using only 400 megs at a time and it errors out..now when doing as 12 min and 16 max threads and 1600 memory to use no errors..least on the smaller renders..will test with a larger render later today..

I even set the gi details to 7...

This is on a space scene.  Will test on the cloud one later...it will take a long time to render.

mmatthe8667

Tangled-Universe

Quote from: mmatthe8667 on February 18, 2009, 10:25:39 am
Whats weird is had it set as 1 min to max of 16 threads with using only 400 megs at a time and it errors out..now when doing as 12 min and 16 max threads and 1600 memory to use no errors..least on the smaller renders..will test with a larger render later today..

I even set the gi details to 7...

This is on a space scene.  Will test on the cloud one later...it will take a long time to render.

mmatthe8667


GI 7??? Seven??
I can imagine that would require quite some memory/thread (especially with clouds) and that TG2 is struggling to handle that.

mmatthe8667

Yeah with the space scene its not to bad..but have a feeling with the cloud one it will really add up on the time frame to render it.

mmatthe8667

Oshyan

First of all, whether it seems to be working (not crashing) with minimum 12 threads or not, you really should *not* be using that setting on a dual core system. In fact even on a system with 8 or 16 execution units (you have 2), the sheer overhead from managing upwards of 8 threads significantly hampers additional performance from adding cores. The "sweet spot" seems to be about 4 *real* cores and 4 threads, after which there are diminishing returns. Above all you *never* want to specify more threads than you have CPU cores. My suggestion for your settings would be max 2, min 1, or just set them both to 2.

A lower resolution render will definitely behave differently by the way. So it's not surprising that it may not be reproducing your error. Resolution plays a big role in these kinds of problems, and in increasing memory use.

7 for either GI quality setting is probably overkill for most scenes too, unless you have very fine geometry, subtle lighting interactions, and perhaps if you are trying to simulate an indoor environment or a close-up. Otherwise it's really just going to pump up your render time unnecessarily. And that being the case, it makes me wonder if you're using other high settings semi-arbitrarily. What are your other detail settings?

- Oshyan

mmatthe8667

The settings was just test on that...not what I normally set.  The only other settings quality wise I normally change is the atmosphere settings and I change the samples to about 156.  Other than that I normally don't change quality settings from default.

mmatthe8667

Tangled-Universe

Quote from: mmatthe8667 on February 19, 2009, 07:52:26 am
The settings was just test on that...not what I normally set.  The only other settings quality wise I normally change is the atmosphere settings and I change the samples to about 156.  Other than that I normally don't change quality settings from default.

mmatthe8667


Hmmm...GI @ 7, atmo samples @ 156...sounds all well and nice etc., but I think you should really go through this post Oshyan wrote quite some time ago:

http://www.terragen.org/index.php?topic=3386.0

Doesn't have to do anything with your current problem, I know, but at least this will save you a lot of time and trouble when you'll have a good idea when and why to use increased settings etc.
Hope this helps as well.

Martin

mmatthe8667

as I said..those settings was at test on the gi quality setting..normally they are at 1 to 2 or even 0...the atmosphere one I set to have it not have all that pixilation and stuff in the image when rendering..

mmatthe8667

Tangled-Universe

Oh a test, now I see the line, sorry missed that :) Nothing said ;D

mmatthe8667

no problem..the link did help me though that you gave...so was nice to have the info anyway..always like to learn.

mmatthe8667