Author Topic: Rendering Clouds problem  (Read 3047 times)

Offline Aagam

  • Member
  • *
  • Posts: 86
Rendering Clouds problem
« on: March 24, 2009, 02:10:03 AM »
I opened up Terragen earlier today and began playing around as I normally do. I was working on some clouds, however when I went to render, the clouds didn't appear, however their shadows did. I attached a picture to show what I got. This has never happened before, and I didn't change anything really (I had just added a cirrus layer).

Offline neuspadrin

  • Member
  • *
  • Posts: 1032
  • Terragen++
Re: Rendering Clouds problem
« Reply #1 on: March 24, 2009, 02:10:58 AM »
can you upload the .tgd?

Also, what is your coverage set to?

Offline FrankB

  • Member
  • *
  • Posts: 3603
Re: Rendering Clouds problem
« Reply #2 on: March 24, 2009, 12:13:35 PM »
If you added a cirrus layer from the default choices, that's a 2D cloud. 2D clouds cannot be seen from above.
Change them to 3D and you should be good.

Cheers,
Frank

Offline neuspadrin

  • Member
  • *
  • Posts: 1032
  • Terragen++
Re: Rendering Clouds problem
« Reply #3 on: March 24, 2009, 12:25:12 PM »
Ah I was wondering about that if it was because it was 2d only.

Offline Henry Blewer

  • Member
  • *
  • Posts: 6333
  • The cooler weather is great!
    • flickr.com/photos/njeneb/
Re: Rendering Clouds problem
« Reply #4 on: March 24, 2009, 12:54:40 PM »
I had this occur. Delete the cloud layer. It seems to be a scaling problem in the denisity shader for the cloud layer. With my situation, the cloud scale was larger than the denisity shaders scale.
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

Offline Aagam

  • Member
  • *
  • Posts: 86
Re: Rendering Clouds problem
« Reply #5 on: March 27, 2009, 08:11:27 PM »
Bah sorry guys, I forgot I asked this. Been so busy.

I tried deleting the cloud layer, didn't work. Tried restarting Terragen, didn't work. Reinstalled it, worked perfectly. Not too sure what happened there but all is good now :)

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12574
  • Holy snagging ducks!
Re: Rendering Clouds problem
« Reply #6 on: March 30, 2009, 06:58:10 PM »
Actually my guess as to what's happening here is that you *are* seeing clouds, and the darker parts are gaps in them showing through to the planet (and shadows) below. The majority of what you're seeing is clouds. But I'd have to see a closer camera perspective or larger render to be sure.

- Oshyan