Holes in the terrain?

Started by domdib, April 03, 2009, 05:04:53 pm

Previous topic - Next topic

Tangled-Universe

Good you sorted this out so far dombib.

I can tell you that the ray detail region padding feature does not resolve this bug.
I used this feature when I first tested this file for you, along with decreasing GI tot 1/1 this saved a lot of time.

Martin

domdib

Thanks Martin. I only hope that Planetside can find out what's causing this odd behaviour. It may be a minor bug, but I guess it will also be doing subtle things to the GI for the scene.

Oshyan

Great catch and thank you for the additional info and examples. This should definitely help us track it down, and I do think it is a potentially important bug.

- Oshyan

Matt

I think I have fixed this now. We'll probably issue an update in the next day or so, including fixes for the number of cores reported on the splash screen, the bug with saving files to the root directory of a drive, and a small bug with some floating parameter windows.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Tangled-Universe

Quote from: Matt on April 08, 2009, 04:30:17 am
I think I have fixed this now. We'll probably issue an update in the next day or so, including fixes for the number of cores reported on the splash screen, the bug with saving files to the root directory of a drive, and a small bug with some floating parameter windows.

Matt


Great work Matt :) Any chance this bug also involved the displacement-cutoff problems?

Matt

You should attempt to solve displacement cutoffs by increasing the displacement tolerance setting on the planet node. But be very careful with that setting because it will increase render time a lot. Unfortunately that's what happens with large displacements.

(Actually the bug was introduced in the changes I made to support the variable displacement tolerance settings.)

Matt
Just because milk is white doesn't mean that clouds are made of milk.

domdib

Excellent news. Sorry to add to your workload right now. :)

Tangled-Universe

Quote from: Matt on April 08, 2009, 05:11:30 am
You should attempt to solve displacement cutoffs by increasing the displacement tolerance setting on the planet node. But be very careful with that setting because it will increase render time a lot. Unfortunately that's what happens with large displacements.

(Actually the bug was introduced in the changes I made to support the variable displacement tolerance settings.)

Matt



Aha, makes me wonder why you added that feature in the first place :)
Can you be a bit more specific about how careful we have to be with that setting? What increments are suggested/acceptable?