Fractal terrain causing vertical jumps??

Started by gpstevens61, May 17, 2009, 11:33:53 am

Previous topic - Next topic


I'm using the Fractal terrain to provide the general topology of the scene but it adds in areas where the surface jumps by 200-400m instantly, making it look like an artificial cliff.  I've got the following settings:  feature scale 1400, Lead-octaves 1, Smallest scale 10, Noise octaves 6, Displacement is applied with amplitude 2000, offset 0, roughness 1, there is no shader set for blending.  The other settings are Scale step 3, stretch factor 3, Late deposition 0.06125, Early deposition 0.25, Early deposition rate 2, Warp amount 0.25.

Any explanations, suggestions gratefully received.


Just reading this quickly, I'd say it has something to do with the scale and displacement. For a hill like landscape with no cliffs, displacement amplitude should not be higher than the fractal scale.

If you play with those settings you might find a result you like.


It would also help to post a TGD and/or example image so we can really see what's going on.

- Oshyan


May 19, 2009, 11:11:13 am #3 Last Edit: May 19, 2009, 11:52:42 am by cyphyr
The only way I could see a simple fractal terrain doing this (NOT Alpine Fractal) is if, under the tweaks tab, you have some quite large nunmbers in the "Noise variation", "Boyancy from varaition" and "Clumping of varaition". A post of the tgd would help :)

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)


There is a bug in the Alpine Fractal which causes discontinuities like this sometimes. I haven't been able to fix it yet.

Just because milk is white doesn't mean that clouds are made of milk.


Here is an example,  thanks

The settings are different but the effect is the same.  One thing I've discovered is that if I change the feature scale by a small amount (say 10) the "cliff" moves across the terrain.


This sounds like it may be an example of the bug Matt is referring to.

- Oshyan


That's OK, at least I won't spend any more hours tweaking random settings to try and get rid of it.