Problems to add Objects!!!

Started by cartmaniax, June 24, 2009, 05:28:30 pm

Previous topic - Next topic


Since one week, I use your Free Edition of Terragen 2. I tried to put a object (tree) on my surface. Everytime i press Add Object-> Population ->TGO Reader and import my *.tgo file i get a error. "Unable to open file. Object Loader: Cannot locate file C:\...\...". Now my question, what could be the problem??. The tgo files aren't corrupted. Also i followed some tutorials and made exactly the same steps. Could it be the problem that I use thee free terragen software?? ??? ??? ???  Pls help me coz i want to make some palms on my island -.- 


You should be able to add up to three populations with the free version. Try putting the .TGO files in the same directory as your scene file.

Henry Blewer

Can you post the terrain file? Check your directory paths. Puzzled...
Forget Tuesday; It's just Monday spelled with a T


June 24, 2009, 07:45:23 pm #3 Last Edit: June 24, 2009, 07:50:45 pm by dandelO
My guess is it's the images for the tree that aren't loading. Put all the object's files in the same folder, this way you won't have the 'c:\documents and etc.....' in the filepath. You might need to edit the .mtl by hand in a text editor to bring it up to date with the object so you can use it in other scenes without seeing the error. Just replace the original filepaths to the images in the .mtl with the new filepaths to the object folder, your object should load correctly everytime this way, in any other scene you import it into.


Forget all that ^^.

I've just realised you said '.tgo files', sorry.

If your .tgo isn't opening images correctly, you need to: Open the .tgo in TG2, reassign all the shaders/images if required, visit the actual folder on your computer where the object is and delete it(you can delete files that are in use in TG already), lastly, re-save the object node as .tgo.

The new shader setup will be saved if you delete the original file, I find that the settings are the same as they were before upon reopening, if I don't delete the original .tgo first. I don't know why this is.


What TGOs are you using? Where did they come from? How large are the files?

Just because milk is white doesn't mean that clouds are made of milk.


June 25, 2009, 01:23:34 am #6 Last Edit: June 25, 2009, 01:27:18 am by Matt
Can you please try putting the object in the root folder of your C: drive (or any other drive) and see if it works from there? I wonder if it may be a problem with the folder names (this might happen on non-English systems).

If that works better, then you may need to move your objects to folders with names that contain only English characters (sorry about that - we will improve this in future). That includes the entire path to the folder.

Just because milk is white doesn't mean that clouds are made of milk.