Rendering crashes

Started by PatGoltz, December 21, 2006, 06:05:57 pm

Previous topic - Next topic

PatGoltz

December 21, 2006, 06:05:57 pm Last Edit: December 21, 2006, 09:54:17 pm by JavaJones
I can reproduce the crashes I am experiencing, though not 100% of the time. However, the crashes continue. Possibly relevant information: 1 gig memory, Athlon 2500, under WinXP. Using the Alpine Shader (it's not giving me any other trouble).

What happens is things are fine until I try to render. It will render the entire picture, and then it just vanishes. It closes itself. It happens pretty consistently with the final renderer, and has happened a couple of times with the preview renderer, which I have set to 800x600. Sometimes the preview renderer renders with no problem at that size, and other times not. Last night, I successfully rendered an 800x600 image with the preview renderer, and then closed the program, reopened, and tried to render the same scene with the final renderer at the same size, and went to bed. When I got up, the program was gone, and both my keyboard and mouse were frozen. I had to do a hard reboot with the button on the machine. I have never actually seen the crash; I have never caught it. It's possible that if I pause it, this may prevent the problem. Sometimes I pause it when it is close to finished and do a screen capture. I can get the entire scene in that little window where it polishes everything.

I don't know that you can replicate this one, but I find it happens about 2/3 of the time. I successfully rendered with the final renderer the first time I tried it, and I think it has crashed every time since. The preview renderer has crashed a couple of times, but most of the time operates with no difficulty.

I have to wait until my credit card rolls over to register, which will happen in a few days. I had almost $500 in car repairs this month.

Zylot

December 21, 2006, 09:42:15 pm #1 Last Edit: December 21, 2006, 09:54:28 pm by JavaJones
I get the same issue with some scenes but not others.  On scenes with water, artificial light, and reflections I'll set it to render, and it'll get to a certain point and then one of the following will happen:

Disappears, just out of the blue.  90% of the time this happens.
Once I got an error message about being unable to write to [something].  If I see it again i can post more details
Another time it just completely locked up.

Previews work fine, but full renders at 800x600 fail every time.

Zylot

December 21, 2006, 11:09:39 pm #2 Last Edit: December 22, 2006, 07:18:34 am by Zylot
"The instruction at "0x77f51d24" referenced memory at "0x3599ef88".  The memory could not be "written."  Clock OK to terminate the program."

You know, I bet if I remove the rgass objects this will work fine, testing now.

Nope, it didn't, but crashed in the *exact* same place, so it's something in the scene causing it.

FrankThomas

don't suppose you have an instance of a .obj in the scene have you ? that crashes mine every single time I render and it hits the position of the instance.

I have a vague recollection that there's a bug in the .obj code

PatGoltz

I had a render on the small renderer crash in the middle of a render. Terragen just vanished. I probably had less memory available than usual. I'm wondering if Terragen runs out of memory if it just crashes. Better it would pause until more memory became available.

The crashes I experienced to begin with had no .obj files, so I don't think that's it. I have .obj files now (a population of trees) but that doesn't seem to make any difference; I have been able to render these successfully in the small renderer. Actually, I'm using the XFrog trees, and I think they are in TGO format.

Zylot

Here's what I know, based on having 4 scenes, two that work and two that do not:

It always crashes at the exact same spot in the render.
That spot so far has always been the forground of the scene.
All my images that crash have used displacement, though one that does not crash uses displacement as well.
At first I thought it was the reflective shaders, or the water, as bother were present in the first problem scene, but this new one just has surface, clouds, displcement, and light source.

If planetside wants me to upload the scene so they can take a look, it's 1 scene and 1 loaded heightmap.

Oshyan

Please do share the scene files for diagnoses. If it's reproducible on our systems then it should help in tracking down the specific cause of the problem.

- Oshyan

Zylot

Alright, I'll post both the problem scenes when I get back home!

David Burnett

I had a rendering crash recently after around 18 hours of rendering.

I've pasted the stack trace as its hanging around in the CrashReporter log.

After quick look over it, it sees to be a Water / Diffuse Illumination issue.

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x21c1d000

Thread 0 Crashed:
0   ...ple.carbonframeworktemplate    0x003279c4 trRenderState::DiffuseIllumination(trFCol const&) + 6172
1   ...ple.carbonframeworktemplate    0x00327be3 trRenderState::DiffuseIllumination(trFCol const&) + 6715
2   ...ple.carbonframeworktemplate    0x00327be3 trRenderState::DiffuseIllumination(trFCol const&) + 6715
3   ...ple.carbonframeworktemplate    0x00327bab trRenderState::DiffuseIllumination(trFCol const&) + 6659
4   ...ple.carbonframeworktemplate    0x00327bab trRenderState::DiffuseIllumination(trFCol const&) + 6659
5   ...ple.carbonframeworktemplate    0x00327be3 trRenderState::DiffuseIllumination(trFCol const&) + 6715
6   ...ple.carbonframeworktemplate    0x00327be3 trRenderState::DiffuseIllumination(trFCol const&) + 6715
7   ...ple.carbonframeworktemplate    0x00327bab trRenderState::DiffuseIllumination(trFCol const&) + 6659
8   ...ple.carbonframeworktemplate    0x00327bab trRenderState::DiffuseIllumination(trFCol const&) + 6659
9   ...ple.carbonframeworktemplate    0x00327be3 trRenderState::DiffuseIllumination(trFCol const&) + 6715
10  ...ple.carbonframeworktemplate    0x00327be3 trRenderState::DiffuseIllumination(trFCol const&) + 6715
11  ...ple.carbonframeworktemplate    0x00327be3 trRenderState::DiffuseIllumination(trFCol const&) + 6715
12  ...ple.carbonframeworktemplate    0x00327bab trRenderState::DiffuseIllumination(trFCol const&) + 6659
13  ...ple.carbonframeworktemplate    0x00327bab trRenderState::DiffuseIllumination(trFCol const&) + 6659
14  ...ple.carbonframeworktemplate    0x00324356 trRenderState::TraceRay(int, trVector const&, trVector const&, unsigned char, unsigned char, unsigned char, trIntersection&, unsigned char) + 23088
15  ...ple.carbonframeworktemplate    0x00324453 trRenderState::TraceColor(trVector const&, trVector const&, unsigned char, unsigned char, unsigned char, trIntersection&, unsigned char) + 89
16  com.apple.carbonbundletemplate    0x0e2787c2 ReflectiveShader::Shade(trRenderState&) + 8498
17  com.apple.carbonbundletemplate    0x0e28e287 WaterShader::Shade(trRenderState&) + 553
18  ...ple.carbonframeworktemplate    0x00321744 trRenderState::TraceRay(int, trVector const&, trVector const&, unsigned char, unsigned char, unsigned char, trIntersection&, unsigned char) + 11806
19  ...ple.carbonframeworktemplate    0x00324453 trRenderState::TraceColor(trVector const&, trVector const&, unsigned char, unsigned char, unsigned char, trIntersection&, unsigned char) + 89
20  com.apple.carbonbundletemplate    0x0e2787c2 ReflectiveShader::Shade(trRenderState&) + 8498
21  com.apple.carbonbundletemplate    0x0e28e287 WaterShader::Shade(trRenderState&) + 553
22  ...ple.carbonframeworktemplate    0x00321744 trRenderState::TraceRay(int, trVector const&, trVector const&, unsigned char, unsigned char, unsigned char, trIntersection&, unsigned char) + 11806
23  ...ple.carbonframeworktemplate    0x00324453 trRenderState::TraceColor(trVector const&, trVector const&, unsigned char, unsigned char, unsigned char, trIntersection&, unsigned char) + 89
24  com.apple.carbonbundletemplate    0x0e2787c2 ReflectiveShader::Shade(trRenderState&) + 8498
25  com.apple.carbonbundletemplate    0x0e28e287 WaterShader::Shade(trRenderState&) + 553
26  ...ple.carbonframeworktemplate    0x00321744 trRenderState::TraceRay(int, trVector const&, trVector const&, unsigned char, unsigned char, unsigned char, trIntersection&, unsigned char) + 11806
27  ...ple.carbonframeworktemplate    0x003257d1 trLightState::Intensity(trVector const&, trVector const&, trVector*) + 4843
28  ...ple.carbonframeworktemplate    0x003263ce trRenderState::DiffuseIllumination(trFCol const&) + 550
29  com.apple.carbonbundletemplate    0x0e273ef8 PowerFractalShaderV3Base::Shade(trRenderState&) + 766
30  ...ple.carbonframeworktemplate    0x00318bdd trRender::RenderFromStack() + 11613
31  ...ple.carbonframeworktemplate    0x003193bd trRender::RenderMore() + 1061
32  ...ple.carbonframeworktemplate    0x01053fb3 juProject::OnFirstCreate() + 40427
33  ...ple.carbonframeworktemplate    0x01009d1a 0x1008000 + 7450
34  ...ple.carbonframeworktemplate    0x010b5c2d UnderC::details::UCMessageRoutingImp::DispatchMessage(UnderC::UCMessenger*, UnderC::UCMessage&) + 169
35  ...ple.carbonframeworktemplate    0x0109b99d UnderC::UCMessenger::SendAMessage(UnderC::UCMessage&) + 111
36  ...ple.carbonframeworktemplate    0x0109bf5e UnderC::UCMessenger::SendAMessage(unsigned long, void*) + 54
37  ...ple.carbonframeworktemplate    0x010a692d UnderC::UCTimer::Fired() + 39
38  ...ple.carbonframeworktemplate    0x010e57c4 UnderC::details::UCMacTimerManager::FireQuickTimers() + 82
39  ...ple.carbonframeworktemplate    0x010dd083 UnderC::details::UCMacEventManagerImp::Run() + 203
40  com.apple.HIToolbox               0x92dcc7eb DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1093
41  com.apple.HIToolbox               0x92dcbe90 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
42  com.apple.HIToolbox               0x92dcbd55 SendEventToEventTargetWithOptions + 55
43  com.apple.HIToolbox               0x92dd325d ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 357
44  com.apple.HIToolbox               0x92dccba2 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2044
45  com.apple.HIToolbox               0x92dcbe90 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
46  com.apple.HIToolbox               0x92dd30f0 SendEventToEventTarget + 56
47  com.apple.HIToolbox               0x92e16d8f ToolboxEventDispatcher + 81
48  com.apple.HIToolbox               0x92e15783 RunApplicationEventLoop + 165
49  ...ple.carbonframeworktemplate    0x010dcf97 UnderC::details::UCMacEventManagerImp::RunApplicationEventLoopWithQuickTimers() + 255
50  ...ple.carbonframeworktemplate    0x010ad2b4 UCMain(int, char const**) + 208
51  uk.co.planetside.Terragen_2       0x00002e69 0x1000 + 7785
52  uk.co.planetside.Terragen_2       0x000027d2 0x1000 + 6098
53  uk.co.planetside.Terragen_2       0x000026f9 0x1000 + 5881


Zylot

I've heard alot about the water rpoblem.   My Issue is, the scene doesn't have water or reflective shaders in it at all ;/

PatGoltz

Well, I haven't gotten too good results with water yet. Last time, it came out black like tar, so I took it out. The first time, I did get some reflections, but the water was very dark. I want to do a sunset over water, but I don't know if I can pull it off, even though I have seen other people do so.

I thought there was a provision for calculating a river, but I can't find it now.

Pat


Matt

Thanks for the crash example Zylot. I will try this out.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

SuperNova

January 04, 2007, 07:37:23 am #13 Last Edit: January 04, 2007, 01:54:13 pm by SuperNova
Since TG2 consumes massive amounts of pagefile, try to raise the maximum level.

Bluefinger

I have a water scene which crashes whenever I try to render it at resolutions of 800 x 600 or above (yes, I have the deep version). I'm seeing if the problem lies with detail settings and the size of the render, but I so badly want to be able to at least render my scene at my desktop resolution. Initial low res renders have been completed without any crashes, so this problem lies with more high-res renders.. I'll post my tgd scene here if it helps to fix the problem, because rendering crashes, IMO, are real serious bugs that have to be sorted out quickly.

Oh, just to note, I have a fairly powerful pc, AMD 4200+ with 2 gig of memory and an X1900XT graphics card, so I don't think its a hardware problem, such as something arising from limited resources.