Errors while rendering

Started by MGebhart, October 25, 2009, 05:58:10 pm

Previous topic - Next topic

MGebhart

Thank you Jo.

You guys at Planetside are always on top of things and respond fast.

I really enjoy this forum. Everyone is helpful, respectful and encouraging, unlike some of the other multimedia forums I belong to.

Thanks a ton.
Marc Gebhart

antti

November 15, 2009, 04:02:07 pm #16 Last Edit: November 15, 2009, 04:05:05 pm by antti
May I borrow this thread as I have encountered the same error messages. First time it crashed whole Terragen, second time Terragen survived but the render was stopped (error messages in the attached images). I am now trying with a little less objects. This is the first time I am trying to do something with my new machine (dual CPU, 24GB RAM, Windows 7 Ultimate) but it is also a new scene so it is difficult to say, which one to blame. First I was running with 6 cores, second attempt was done with 4 cores. I'll let you know what happens with my third attempt.  

Henry Blewer

Antti, this may be the result of some memory allocation fault. Try using the Pre-Allocate subdivide cache. This will grab the memory the program needs. You may have another program running which does not handle memory correctly; it may be overwriting memory T2 has called for.
The reason I think this may have happened is one of the errors. The one about the subdivide cache. It's a guess, so...
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

antti

Thanks for the suggestion, I will try the preallocation thing as the third attempt was not successful (got the runtime error quite early on).

Kadri

Reducing the subdivide cache (in the advanced tab in full render) helps too. It is in the error mesage.  If it is 400 try 300 - 200 or lower too.

Kadri.

Oshyan

This is definitely a memory-related issue. I assume your Windows 7 is 64 bit, so you should have up to 4GB for TG2, in practice about 3.5GB. The thing is the more threads you use, the more memory is needed for render caches (the cache size is split among each thread). I use up to 8 render threads with pretty complex scenes and it works well, but you need to keep the cache size down. 100MB per thread is usually fine, but in some extreme cases you need to reduce to 50MB per thread. It will warn you about this as a potential performance issue, and sometimes it *will* make things a bit slower, but you'll have a better chance of succeeding. The one thing I do see a lot is people assuming that setting a larger render cache is a good idea, for performance or whatever, but this is definitely *not* a good idea, especially in complex scenes.

In the future when TG2 has a 64 bit binary, memory issues like this should be a thing of the past on high-memory systems.

- Oshyan

antti

November 16, 2009, 02:39:28 pm #21 Last Edit: November 16, 2009, 04:06:32 pm by antti
Thanks for the helpful information. Today I managed to finish the render (see picture). Preallocation of subdiv cache did not resolve the problem (another crash) but then I changed the size of subdiv cache to 100Mb and I also divided the render to two crops that I ran simultaneously and finally combined together. By the way, even though I set 100Mb for the subdiv cache, Terragen said that the "size was automatically increased to 200 Mb so that each thread has 50 Mb" (I was running with 4 cores per process). Is this OK or is there a way to force the 100 Mb setting if I encounter more serious problems with some other render?

Edit: Now I noticed that Oshyan was talking about memory per thread and not about the whole cache so I was running now with 50 Mb per thread which definitely was a working solution

Oshyan

As you noted from the error message, 50MB per thread is currently the minimum.

- Oshyan