atmosphere turns on during animation render

Started by Postglory, January 09, 2010, 09:47:43 pm

Previous topic - Next topic

Postglory

January 09, 2010, 09:47:43 pm Last Edit: January 09, 2010, 10:38:05 pm by godzooks
Hi I am having a problem with the atmosphere during an animation render, in one frame it's not there then it turns on in the next frame this changes the image with a blue tint, it happens when the camera pitches up from looking at the ground to see the horizon.  This makes me think that the frames at the beginning of the animation were being rendered without the atmosphere and will have incorrect colour.  Maybe it has something to do with the GI but thats only a guess.

I am also getting glitches on the fake stone shader, I have tried turning the 'blend as stone density' off but this has no effect.

Any ideas?
thanks

Oshyan

What you're seeing is probably a GI-related issue. Try turning off GI (as a test) To see if it still happens.

Can you show an example of the Fake Stones problem?

- Oshyan

Postglory

Here is a link to the sequence on vimeo, the stones error is less apparent but looks like it is in the fake shadow of only a few stones.
http://www.vimeo.com/8652516

I will check the other error in the atmosphere switching on soon, using the GI turned off

Kadri

Quote from: godzooks on January 10, 2010, 01:20:38 pm
Here is a link to the sequence on vimeo, the stones error is less apparent but looks like it is in the fake shadow of only a few stones.
http://www.vimeo.com/8652516

I will check the other error in the atmosphere switching on soon, using the GI turned off


Private video ?


Kadri

Thanks , Godzooks .

I see what you mean .

Beside this issue your camera moves are incredible natural . Like a hand held camera. How did you make it , Godzooks ?

Kadri.

Postglory

January 10, 2010, 10:41:42 pm #6 Last Edit: January 10, 2010, 10:43:19 pm by godzooks
The camera move is an import from a match move I did last year.
It looks like it was the GI making the atmosphere turn on suddenly

Oshyan

I agree, nice camera move. What is your Detail Blending setting? And main detail?

- Oshyan

Kadri

Quote from: godzooks on January 10, 2010, 10:41:42 pm
The camera move is an import from a match move I did last year.
It looks like it was the GI making the atmosphere turn on suddenly


Thanks  :)

Postglory

Hi the detail blending was 0, the main detail was 0.6 and AA5.

Tangled-Universe

Quote from: godzooks on January 18, 2010, 12:31:32 am
Hi the detail blending was 0, the main detail was 0.6 and AA5.


Detail blending is important in rendering animations, you might want to increase it, up to 1.
This might add some rendertime.

I don't have much experience with animation yet, but for terrain-anims I found that GI detail @ 1 and sampling @ 3 gives nice results, depending on the lighting conditions of course.
As far as I've understood you can solve a lot of issues with increasing the detail blending and the GI sampling. If a sampling of 3 does not work then you could go for 4. If even that is not sufficient you might also consider comparing rendertimes for GI detail 2 with sampling at 2 or 3 and see if that gives desirable results.

Cheers,
Martin