white dots & black edges

Started by Miingno, February 28, 2007, 02:47:48 am

Previous topic - Next topic

Miingno

Hi there! I'm new to this forum, but I think it's the best place for my problem.

I wanted to add some XFrog plants to my TG2 renders. It was no problem to convert them to .obj => .tgo
But the result is not really so nice:



Here a closer look:



What I now wanna know.. Is there a way to convert them that such things won't happen? Or is there a way to fix it?
Thanks for any comments! I hope you can help me, that I never have to see things like this again :)



Oh, and by the way: sorry for my bad English. I'm from Switzerland and English isn't really a well known language here  ;)

old_blaggard

Are these the XFrog public plants?  If so, it's really (and I mean *really*) hard to get them to look good.  There are issues with their alphas (it looks like that's the problem here) as well as their textures.
http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

Miingno

thanks for the answer ^^!

Yep, these are all XFrog Plants. I already thought that it may has something to do with their alphas.
Is there a way to solve these "problems"? Or should I just wait till these issues are fixed?

sonshine777

Quote from: Miingno on February 28, 2007, 09:51:29 am
thanks for the answer ^^!

Yep, these are all XFrog Plants. I already thought that it may has something to do with their alphas.
Is there a way to solve these "problems"? Or should I just wait till these issues are fixed?


One thing you can try is to convert the .png texture files to a .tif format (do in PhotoShop or other image editor). Then replace the .png file the new .tif textures in TG2. Once you have done that you can save the .tgo file over itself and the next time you use that plant it should work.

I will mention that you may have to clean up the .png file before saving it to a .tif.

Hope this helps. :)

Miingno

Quote from: sonshine777 on February 28, 2007, 11:31:22 am
One thing you can try is to convert the .png texture files to a .tif format...


I could do that, if there would be any .png textures ^^; All textures I have are already in the .tif format. But I can try to clean them a bit, the edges really seem to be a bit too white.

old_blaggard

Yeah.  From my experience, the alphas in the XFrog plants all have one extra pixel of white on all sides - as far as I know you have to remove it manually -_-.
http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

sonshine777

Quote from: old_blaggard on February 28, 2007, 12:26:54 pm
Yeah.  From my experience, the alphas in the XFrog plants all have one extra pixel of white on all sides - as far as I know you have to remove it manually -_-.


My experience too.

Will

The world is round... so you have to use spherical projection.