Planetside Software Forums

Support => Terragen Support => Topic started by: Kadri on August 09, 2013, 11:24:19 pm

Title: Disabled node still affecting cloud node.
Post by: Kadri on August 09, 2013, 11:24:19 pm

I tried to connect an image or power fractal node to change the color of a cloud.
When you disable that color node, but don't break the connection , the cloud gets still kinda tinted.
More then one input of the cloud node does show the same behavior .

TG 3.0.05.0  64 bit , Windows 8 64 bit.
Title: Re: Disabled node still affecting cloud node.
Post by: Kadri on August 11, 2013, 02:18:14 am

Can anybody try this and confirm?
Title: Re: Disabled node still affecting cloud node.
Post by: Dune on August 11, 2013, 04:01:53 am
Not with me; win 7 32 bit.
Title: Re: Disabled node still affecting cloud node.
Post by: Kadri on August 11, 2013, 04:12:02 am

Can you try it with the light-color inputs on the right side Ulco?
Title: Re: Disabled node still affecting cloud node.
Post by: Dune on August 11, 2013, 04:34:29 am
Ah, I see what you mean. Yes, confirmed. Strange. Color of fractal is yellow. I'll file a bug report.
Title: Re: Disabled node still affecting cloud node.
Post by: Kadri on August 11, 2013, 04:54:37 am

Thanks Ulco :)
Title: Re: Disabled node still affecting cloud node.
Post by: Matt on August 11, 2013, 05:59:08 am
The output of a single, disabled shader is black. This looks like it's probably working as expected. This is the same as what happens when you connect disabled shaders as blend shaders or any other similar situation.

Matt
Title: Re: Disabled node still affecting cloud node.
Post by: Kadri on August 11, 2013, 06:42:01 am

From your point of view you are right probably Matt
but until now i thought that a disabled node and a disconnected node get the same output.
I did not think about this even.

Interestingly i don't remember anyone talking about this.
I searched for the problem for some hours until i thought this is a
prerelease maybe it has a bug and looked at those disabled shaders .
This could be one of the reasons i got sometimes strange , inconsistent results.

I don't like this behavior because from now on i will always think if that disabled node does something or not.
So i will prefer disconnecting them.

Good to know at least.
Thanks Matt.

Title: Re: Disabled node still affecting cloud node.
Post by: Dune on August 11, 2013, 09:13:29 am
Good to know indeed, Matt. Sorry for filing at the test forum.
Title: Re: Disabled node still affecting cloud node.
Post by: WAS on May 13, 2018, 02:09:59 pm
I noticed if you have a ambient colour picked, and set it to 0 (black), it will still emit the colour original picked on a very, very faint level, only really noticeable with a white light source and planet/atmosphere/sun disabled.
Title: Re: Disabled node still affecting cloud node.
Post by: Matt on May 13, 2018, 11:35:41 pm
Quote from: WASasquatch on May 13, 2018, 02:09:59 pm
I noticed if you have a ambient colour picked, and set it to 0 (black), it will still emit the colour original picked on a very, very faint level, only really noticeable with a white light source and planet/atmosphere/sun disabled.


Can you send me (or paste here) a node where this is happening?
Title: Re: Disabled node still affecting cloud node.
Post by: Matt on May 13, 2018, 11:39:57 pm
You can copy a node and paste it into a text editor. There you should be able to see the full precision values of the ambient colour, and see if it's anything other than "0 0 0".

Matt
Title: Re: Disabled node still affecting cloud node.
Post by: WAS on May 30, 2018, 01:48:08 pm
Quote from: Matt on May 13, 2018, 11:39:57 pm
You can copy a node and paste it into a text editor. There you should be able to see the full precision values of the ambient colour, and see if it's anything other than "0 0 0".

Matt


I'll search my nebula files. I left one of them saved with the issue.

Edit: I'm pretty sure I found the file, and it doesn't seem to be effecting the clouds at all like I had noticed before. Whether settings, or from updating from 4.1.11