Planetside Software Forums

General => Terragen Animation => Topic started by: JasonArcher on September 18, 2013, 06:57:31 pm

Title: Shadow "Pooling"
Post by: JasonArcher on September 18, 2013, 06:57:31 pm
I encountered an odd issue with shadows seeming to rise out of the ground and "pool", for lack of a better word, on a fly-by animation. Has anyone encountered this issue? I currently have ray traced shadows set to on.

I've included a short clip of the first segment of the animation as an attachment to this post. The effect is visible toward the very end of the animation on the surface of the asteroid.

Title: Re: Shadow "Pooling"
Post by: Oshyan on September 18, 2013, 07:09:54 pm
That's definitely an odd effect, but it's hard to say what's going on. It almost looks like clipping of some kind. Is this a TGD that you could share so we could have a look?

- Oshyan
Title: Re: Shadow "Pooling"
Post by: JasonArcher on September 18, 2013, 07:59:12 pm
Quote from: Oshyan on September 18, 2013, 07:09:54 pm
That's definitely an odd effect, but it's hard to say what's going on. It almost looks like clipping of some kind. Is this a TGD that you could share so we could have a look?

- Oshyan


Certainly. :) File attached -- I appreciate you taking a look.
Title: Re: Shadow "Pooling"
Post by: Oshyan on September 18, 2013, 08:06:17 pm
Ah. I believe it's because you have "Lock Subdiv to Frame" turned on and set to frame 0. This terrain is too far from where the camera starts to be properly subdivided as needed for this frame to render correctly.

Did you enable that to solve some specific issue? If not, I'd suggest leaving it off.

- Oshyan
Title: Re: Shadow "Pooling"
Post by: JasonArcher on September 18, 2013, 08:24:21 pm
Quote from: Oshyan on September 18, 2013, 08:06:17 pm
Ah. I believe it's because you have "Lock Subdiv to Frame" turned on and set to frame 0. This terrain is too far from where the camera starts to be properly subdivided as needed for this frame to render correctly.

Did you enable that to solve some specific issue? If not, I'd suggest leaving it off.

- Oshyan


Ah, thank you.. I'll give it a try, though I may have to turn it off to render those frames where the pooling is occurring and then re-enable it if that's possible -- I found that having it off was causing very noticeable shadow popping, though that was in Terragen 2.5... Haven't given it a try in 3 yet.
Title: Re: Shadow "Pooling"
Post by: Oshyan on September 18, 2013, 08:30:23 pm
It is one possible solution to shadow popping, though certainly not the only one, nor necessarily the best. Have you tried Ray Detail Region Padding?

- Oshyan
Title: Re: Shadow "Pooling"
Post by: JasonArcher on September 18, 2013, 08:40:40 pm
Haven't tried that yet. I'll give it a shot and see if that fixes it.
Title: Re: Shadow "Pooling"
Post by: Oshyan on September 18, 2013, 08:42:14 pm
Try a value of 0.5 to start.

- Oshyan
Title: Re: Shadow "Pooling"
Post by: JasonArcher on September 18, 2013, 10:40:40 pm
Still seeing some popping at 0.5 -- I'll take it up a a bit farther and see what happens.
Title: Re: Shadow "Pooling"
Post by: Oshyan on September 18, 2013, 10:42:58 pm
That looks more like a detail issue since it's happening center screen. The ray detail region padding is intended to deal with shadow casting geometry *off* screen. Did you use the Animation Check button on the Renderer Sequence/Output tab? If you've already done that, then increase detail (I know you're trying to save time on the test, but for this kind of issue it's not an accurate representation).

- Oshyan
Title: Re: Shadow "Pooling"
Post by: JasonArcher on September 18, 2013, 11:08:09 pm
So far it looks clean with the detail cranked up -- and I had overlooked doing the animation check.