Planetside Software Forums

Support => Terragen Support => Topic started by: JimB on January 02, 2007, 08:00:17 am

Title: Cloud white artefacts on hilltops?
Post by: JimB on January 02, 2007, 08:00:17 am
I just finished rendering the image below, and noticed something with the hilltops. There are no white coloured surfaces, and it's happening to the trees as well. Is that the clouds causing the middle and far right hilltops to go white (It ain't snow)? The cloud pattern seems to be in there.

Cheers,
Jim.
Title: Re: Cloud white artefacts on hilltops?
Post by: Matt on January 02, 2007, 05:48:47 pm
Hi Jim,

This is a bug in the cloud rendering which is somewhat related to the horizon problem you might see if you put the camera within the clouds (even though that is not the case here). In other words, they will be fixed at the same time. It is a bug in the visibility ordering of objects, clouds and atmosphere, and is really a problem with objects obscured by dense cloud and fairly dense atmosphere.

This can be avoided by increasing the altitude of the clouds just enough so that they don't obscure the top of the mountains. In many situations you can get away with it, but unfortunately apparently not here (probably due to the thick atmosphere below the cloud).

Matt
Title: Re: Cloud white artefacts on hilltops?
Post by: JimB on January 02, 2007, 05:56:37 pm
Thanks Matt. It took me by surprise as I've been doing renders with the terrain digging into the clouds. I'll make sure I check close in before clicking render from now on  ;)
Title: Re: Cloud white artefacts on hilltops?
Post by: crazymonkey on January 02, 2007, 06:22:20 pm
interesting little bug :P great image btw ;D
Title: Re: Cloud white artefacts on hilltops?
Post by: JimB on January 02, 2007, 08:09:57 pm
Thanks monkey.
Title: Re: Cloud white artefacts on hilltops?
Post by: efflux on January 03, 2007, 07:56:22 am
Very nice cloudscape despite the problem.