Planetside Software Forums

Support => Terragen Support => Topic started by: Hyncharas on March 27, 2008, 06:59:40 pm

Title: Crash with cloud layers
Post by: Hyncharas on March 27, 2008, 06:59:40 pm
I only got the Preview recently as an unregistered version, just to try it out before I think of upgrading it to commercial.  Having tried it twice now it seems to crash whenever you add cloud cover; no matter what altitude it is...

My specs are a Dell M1710 with Intel Mobile Core2Duo 2.33GHz, 4GB RAM and XP Pro.  Any ideas?
Title: Re: Crash with cloud layers
Post by: Oshyan on March 27, 2008, 09:03:49 pm
I split this topic from the original thread as it was really a different subject.

Unfortunately that's not much information to go on for diagnosing the problem. Does it crash *immediately* when you add a cloud layer of any type? Or does it only crash once you render? When it crashes does it give you an error message, and if so what does it say? If you are able to save the scene before it crashes, it may help to attach it here (use "additional options" at the bottom) so we can take a look at it.

- Oshyan
Title: Re: Crash with cloud layers
Post by: Hyncharas on March 27, 2008, 09:47:44 pm
It appears I have manged to get it working partially without crashing, but I can't get them to work at the height I wanted to.

Sometimes it crashes with the "trImage allocation" error he mentioned earlier, and sometimes it just closes with no errors at all -- it's as if the power necessary to render the clouds far outweighs that of the ground-terrain itself.  Either problem occurs after about 30-45secs into adding the cloudcover.  Unless I'm really quick to set it down to 3,000 elevation or below, I don't even get to rendering the scene without the interface suddenly disappearing...

The default elevation seems to be the issue.  Even if the heightmap is really large to "supposedly" accomodate a higher elevation, it seems there's only so much that the workspace can handle at the moment without the cloudcover crashing the rest of the software.  Perhaps this will be fixed when the engine has been stabilized.
Title: Re: Crash with cloud layers
Post by: Oshyan on March 27, 2008, 10:00:38 pm
I can assure you that what you're experiencing is not, by your description, normal or commonplace. I have used and seen used elevation values for clouds ranging from ground level (literally 0) to *millions* of meters (for some experiments others have done to simulate nebulae in space). In general the cloud system is fairly robust and is seldom the cause of any crashes.

To my knowledge the trImage errors only occur in the following circumstances: A: Rendering at high resolution or in a memory limited scenario and the primary render buffer runs out of memory - this should not be an issue for you with 4GB of memory. B: Attempting to render an imported object with a high resolution image map texture, or otherwise utilizing/loading a high resolution image map (as a mask or ground texture for example). C: In some cases missing images or other inconsistencies can trigger this as well, but it's much more rare. From what you've described none of those should be occurring.

Let's step back a moment and make sure that the specific scenario you're describing is fully understood. You are saying that the problem occurs only *and always* when you add a cloud layer that is above 3000 meters. You haven't mentioned any other details about the scene so I'm assuming this happens *even in the default scene*. Testing that is extremely important because the default scene should have absolutely nothing in it that would trigger the trImage error, and the default image render resolution is low enough that it also would not trigger it, even on a system with very modest specifications (which yours most certainly is not).

Assuming it does happen in the default scene I'd say there must be something unique to your configuration as I certainly can't reproduce that problem here, and I have not heard any other report of anything similar from anyone else here. The most likely culprit would normally be graphics drivers, especially considering you are probably running on a limited mobile graphic chipset (although you didn't specify), however if the error you're seeing is really trImage-related rather than specifying a dll like OPENGL32.dll or NTDLL.dll, then that explanation seems questionable. It's worth checking for updated drivers anyway of course. You might also try excluding TG2 from the "Data Execution Prevention" function of Windows XP as this can sometimes be overzealous and has caused crashes in the past.

Hopefully we can pin this down with a bit more troubleshooting.

- Oshyan
Title: Re: Crash with cloud layers
Post by: Hyncharas on March 27, 2008, 10:20:01 pm
Occassionally I do get NTDLL.dll errors, though this is more of a BIOS problem than general software.  The M1710 has only been active for a little over a year because of a manufacturing glitch when they produced the systems... we also have a M1730 though I haven't tried the software on that yet.  My graphics card is an Nvidia GeForce 7950GTX -- no M1710 laptop can go higher than that because of how its mainboard was developed.

I also have Vue Infinite and I've never seen the error occur on that... on the other hand, the two engines may have differences in how they process cloudcover.

I will, however take your suggestion into account and update my graphics drivers.  I'll let you know on the results.
Title: Re: Crash with cloud layers
Post by: Oshyan on March 27, 2008, 10:22:33 pm
TG2 and Vue are most definitely very different in how they handle things, but Vue is also fairly demanding and finnicky with OpenGL issues so it's good to know that you haven't had problems with it.

Do let us know if this happens in the default scene when *only* adding a cloud layer (with no other changes before that).

- Oshyan
Title: Re: Crash with cloud layers
Post by: Hyncharas on March 29, 2008, 01:13:56 pm
Dell handles the updates for the card.  At the moment it hasn't been updated since April-2007 and a new update has not been released yet.

In the meantime I took your advice and tried to replicate the problem I had earlier.  I was also able to free 17GB more space by backing up some things; in the event it is a hard drive issue... the error has happened again when placing the height of cloudcover at 3001m or above, but doesn't if it is set to 3000m!  Coverage or Density does not appear to be a factor, as it is all focused on the height of the clouds themselves.  Here is an image of the error that is displayed:


Fortunately the software didn't crash this time (perhaps because of the extra memory to play with).  The heightmap of the landscape is 10,000m with a diameter of 25,000 and does not seem to create any errors before adding cloudcover - the purpose of this is to test the engine for a non-commercial "Machinima" project for a community team...

A glitch does seem to occur with the Objects panel, however, as it cannot keep choices open when trying to switch submenus when selecting a Surface Shader.
Title: Re: Crash with cloud layers
Post by: Oshyan on March 29, 2008, 10:34:17 pm
I would wager this has more to do with render settings, either image dimensions, or crop settings (make sure crop rendering is *off* next time you test this). Try rendering with default renderer settings and see if it happens again.

Also, as I mentioned before, it's extremely important to know whether this also happens for you in a *default scene*. My guess is it doesn't, in which case it's almost certainly something to do with your particular scene settings, and although it seems to be the cloud layer height that triggers it, it's most likely not actually caused by it, although it may somehow be related.

If it does not happen in the default scene, please send use the .tgd that causes it. You can email it to support AT for privacy's sake. Please include any terrain files the scene depends on.

- Oshyan