Planetside Software Forums

Support => Terragen Support => Topic started by: neuspadrin on May 14, 2009, 11:35:10 pm

Title: Object populations and Resolution
Post by: neuspadrin on May 14, 2009, 11:35:10 pm
Heres something I've noticed when trying out some cropped renders, and hers an extremely cropped view of the problem to save me long render times right now, but it effects more then just this area.

The ONLY difference in the first image and the last is the first is 800x500, and the second is 1680x1050 (Both 1.6 ratios)

Where'd half the object go?
Title: Re: Object populations and Resolution
Post by: neuspadrin on May 15, 2009, 12:59:17 am
I'm pretty sure I've narrowed it down to clipping as slight camera movements help it... does clipping distance change from a resolution increase? Not really sure yet though...
Title: Re: Object populations and Resolution
Post by: Matt on June 25, 2009, 07:03:45 am
Can you please send me a project file and associated object so that I can test this? I've never been able to make this problem occur.

Matt
Title: Re: Object populations and Resolution
Post by: Henry Blewer on June 25, 2009, 12:20:59 pm
I have run into this problem also. http://farm4.static.flickr.com/3576/3546918114_1c49163232_o.jpg
I have the tgo file, but for this render I moved the camera and did not save the file. This effect used to have with Byte By Byte's Sculpt 4D when the camera was set to near an object.
Title: Re: Object populations and Resolution
Post by: neuspadrin on June 25, 2009, 04:53:34 pm
i'm a little busy til this weekend but ill get around to it then.  ill play with it a little and see if i can strip it down to just bare elements of whats causing issues.
Title: Re: Object populations and Resolution
Post by: Matt on June 25, 2009, 09:04:50 pm
Thanks.
Title: Re: Object populations and Resolution
Post by: neuspadrin on June 27, 2009, 02:52:25 pm
stripped it down, its working slightly differently right now... but its still got generally the same issue going on and doesn't take forever to render ;)

heres a zip with everything good to go when unzipped.  just has walli's free grass being used.

http://www.mediafire.com/?lzzmmlzwjuk
Title: Re: Object populations and Resolution
Post by: Matt on July 03, 2009, 07:04:52 pm
I've fixed the bug that was causing this object to break at higher resolution or detail settings. Thanks for the fast-rendering files to test with - they were really useful for tracking down the cause.

However, there is still another clipping problem as seen in http://forums.planetside.co.uk/index.php?topic=5012.0 which I haven't figured out yet.

Matt
Title: Re: Object populations and Resolution
Post by: neuspadrin on July 03, 2009, 11:15:10 pm
awesome cant wait to give that render another go next patch :) bummer bout the clipping but i felt like this was somewhat different as its happens on objects that are sometimes not clipped.