Author Topic: Textures don't move with the object ?  (Read 702 times)

Offline midnight_stories

  • Member
  • *
  • Posts: 15
Textures don't move with the object ?
« on: December 17, 2017, 01:33:00 PM »
Is this a bug when you move an object the texture coordinance for that object dosen't move with it.
E.g I have an ordinary sphere made by TG, I map some planet textures on it use spherical map.
then I move it the texture go all over the place. What's going on ? it must be something basic I'm missing.
Plus another thing I found I couldn't select the sphere in the render window, I can use the heading and distance.
But no real way to select it in the main view and drag it around, I am using a spherical camera so that might
have something to do with it. I've used TG for 3 years on and off and I still feel like a beginner. Just made
an environment HDR pack and DAZ and had great success with it. But it's still frustrating Lol!

Offline Dune

  • Terragen Alpha Tester (Win)
  • ***
  • Posts: 13522
  • Corkscrew Bird
    • www.ulco-art.nl
Re: Textures don't move with the object ?
« Reply #1 on: December 17, 2017, 04:44:39 PM »
The image map applied is centered where the center of the sphere is. So when you move the sphere it will be distorted, and you have to set the new locations from the sphere in the image map after moving it.
If you can't select it might be that you're too close, and you may need to click at the right side of the preview window and hit ] (or [), something like that. But I don't remember what it's called.
In case you still haven't seen enough of my work: www.ulco-art.nl

Offline midnight_stories

  • Member
  • *
  • Posts: 15
Re: Textures don't move with the object ?
« Reply #2 on: December 17, 2017, 08:14:58 PM »
Thanks for the help , I think I understand. Wow I haven't seen a 3d program have to do that for about 25 Yrs, not exactly a feature I'd be boasting about, but at least I knew what's going on. I'll try those key short cuts Cheers !

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12129
  • Holy snagging ducks!
Re: Textures don't move with the object ?
« Reply #3 on: December 18, 2017, 10:06:34 PM »
When objects are mapped with U/V then you can move them and the textures move with them. For all other mappings you need to manually specify the image map coordinates.

The [ and ] keys adjust the clipping plane distance and this is necessary because Terragen works with a huge range of scale that is outside of the average z-buffer depth of most graphics cards and OpenGL capabilities.

Also note that you can easily select things in your scene in the 3D preview by right-clicking in the 3D Preview and choosing the object from the pop-up menu. However be aware that object selection and movement is not reliable and should be avoided in the RTP (Ray Traced Preview).

- Oshyan

Offline midnight_stories

  • Member
  • *
  • Posts: 15
Re: Textures don't move with the object ?
« Reply #4 on: December 18, 2017, 10:25:56 PM »
RTP (Ray Traced Preview)
I think that's the key I was looking for, it's super tough trying to move planets and card objects
by just typing in the position. I've tried a few times to put a nebula in and can't do it.
The only other thing I haven't tried is using a 2nd background with a smaller radius and transparent image.
If that's even possible!
Thanks anyways guys !

Offline N-drju

  • Member
  • *
  • Posts: 1183
  • A ship in port is safe... well, fine by me.
Re: Textures don't move with the object ?
« Reply #5 on: January 08, 2018, 11:32:57 AM »
I think that should be possible when you use two image maps. One colored, for the render, and exact same image in greyscale, to use as an opacity image, leaving out exactly the color specks that you are after.
"Error 404 - pun not found."