HUGE GI BUG?

Started by dandelO, May 31, 2010, 09:01:30 pm

Previous topic - Next topic

dandelO

May 31, 2010, 09:01:30 pm Last Edit: June 01, 2010, 04:54:53 pm by dandelO
*FINAL EDIT* I'll leave the following monologue up and posted without editing my idiocy. Purely for comic relief. You never know when you may need a pick-me-up. You can rely on me to give you something to laugh at, at least, if nothing else. Is there a TG2 Darwin award? I'll beat you all hands-down! :D :-[ Read on...
Planetside staff: You may want to move this thread to the General Discussion forum, or, possibly, a brand new forum all on its own called, 'Numbc#*%ts Only!'


This is ridiculous!
I posted the recent caustics image and said the .tgd I was sharing had really high GI values but, 'don't be alarmed, it's quick', and all that nonsense...

This was quite an old file that I originally made in Terragen 2 TP 3 or 4, I think but, that's the thing... opening this .tgd again, I was getting away with really ridiculously high GI detail and sample quality, that I had put down to there not being any sky/atmosphere being rendered.

I've since opened the recently shared .tgd(saved in TG2.1) to update it a little, and I really, really, REALLY could not have even possibly considered waiting on even one render bucket to complete its GI prepass. It was as you'd expect with GI settings of 3/12, really, really, REALLY long.

So, here's the thing. Will someone please download this old .tgd(the original one from way back), do not edit anything, visit the render tab directly, and input some really preposterous GI settings that you'd never use. I can crank it and crank it, no matter how high, it seems. (You'll see that all the newer features, RTO/RTE, pixel filters, supersampling, etc. are all unchecked or disabled because they weren't around when the file was made, doesn't matter, enable anything new to do with GI and rendering, it all works as it should except 100 times faster).
When testing if this was a bug I took this snapshot of TG2's program and render window as it was rendering:

[attachimg=#]

LOOK AT THESE GI VALUES! :o And look at the short amount of time it's taken.(the render window you see here is only drawing GI prepass, not actually rendering yet). The prepass is pretty much filling every pixel and yet, 3 minutes 22 seconds! ??? That might not be a lot for some of you running some of your supercomputers but, for me that is completely insane, and actually, if I'd put some more thought into it, unthinkable!
Just to be clear, it isn't keeping to the same speed for all prepasses at different levels of detail, raising settings is raising time but, by hardly anything at all.

So, I can reproduce this(not sure if it's with all old .tgd's but certainly with this one). Open it, crank GI, hit render and Terragen flies through the GI prepass, and it seems, at the correct quality, I have rendered about 5 or 6 1024px versions of this .tgd while editing the caustics shaders and I should never have been able to. I did not save and exit TG once since opening it during this time. When I was done with the shaders I obviously closed the program.
As is normal for me, I always update things so, when I opened TG2 again earlier and went with the recently saved(TG2.1) version of the scene. 'CRUNCH! NO WAY, SIR! WHAT AM I MEANT TO DO WITH THAT?' Said the computer. ???

Here's the file: [attachimg=#]

Tell me what's going on on your end... And, if it is as fast for you, join me in a petition to have Matt make it the normal prepass speed! :D ;)

I am very confused by this. :-\

dandelO

I'm up to GI relative detail of 12 now. Still extremely fast. The image simply appears to be rendering itself in dots with no missed pixels at all.

Bedtime.

dandelO

May 31, 2010, 09:22:46 pm #2 Last Edit: May 31, 2010, 09:30:31 pm by dandelO
Also, the .tgd is set up for a single render thread. You can raise this as well to make it even quicker if you're multithreading. I'm not certain if this was made in TG before multithreading because I used have to use only one thread on my old pc as it would shut down, I've no idea what technology preview this was made in, sorry.

It was made in the free non-commercial version, though. That much I know.

dandelO

And, I've now checked. It is working for lots of my old .tgd's from around the same time(October 2008). As long as I don't resave them in this version, it continues to go very fast.

dandelO

June 01, 2010, 10:23:20 am #4 Last Edit: June 01, 2010, 10:25:47 am by dandelO
This file, and all the rest that appear to be working in the same way, was last saved in Terragen 2(TP5) v.1.9.99.1.
I forgot I could just have a look inside the .tgd file.

dandelO

June 01, 2010, 12:21:50 pm #5 Last Edit: June 01, 2010, 04:55:34 pm by dandelO
This post is more to keep my sanity than anything else, sorry for the multiple replies.

2 comparison shots of TG2.1 rendering this scene.

First the old TG1.9 file(attached in the first post) with GI settings cranked, AA filters on, bloom/MV jittering/detail jittering all enabled:

[attachimg=#]

and then secondly, the file that has been edited and saved in TG2.1, with the same render settings. :

[attachimg=#]

Both are captured rendering for around the same length of time. Very weird, no? I might as well attach the .tgd that's saved in TG2.1, too.
You(I) can edit the first, old .tgd to make all the render settings the same as this one and watch the difference in speed, it's remarkable!

[attachimg=#]

I hope it isn't just me that's experiencing this, I think everyone would really love GI prepasses to go this fast. :o

EDIT: *Sorry. I'm 100% sure now that it is NOT to do with which version has saved the .tgd.
I've, just now, opened the first one in TG2.1, edited the render settings to the above and then saved it. Reopening this file is still as fast to render. It must have something to do with the editing I've done between the first one and this version in this post.
All I can think that I have done, though, was to DROP atmo' samples from 36 to 32 in the one that is in this post, that would affect render time. And that's backwards!
My head's now in ruins with this, I'll leave it in you guys capable hands! :D*


dandelO

:-X

"Hey, dandelO, you're pretty clever, eh?" 8)

"Hmmm, well, I'd like to think I'm not stupid, if that's what you mean..." ;D

"Very good." :P "So, about this 'RENDER ATMOSPHERE' checkbox in the planet node... What would you think of that?"

"...
...
...
...

'DOH!"


"Idiot!" ::) :D


:-[  

I'm off now, to shoot myself in the head. Be seeing you later, maybe...

Henry Blewer

These would probably be very extreme GI settings on my machine. It's very slow these days (5 years old) compared to the newer machines.
Still, the water and the specular highlights look great. Nice work as usual! 8)
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

dandelO

Oh, Henry. They are very high on anyone's machine, in any normal render. Please go back and reread the thread!

At least I saw my mistake, after posting all that nonsense ^^, rather than have someone have to tell me it!

Oh how we(me and myself, that is) laughed! :D

Kadri


Do you know DandelO , i like you (no sarcasm )  ;D

dandelO

You pity me! But, thanks. :)

Seth


dandelO