Color Banding in Atmosphere

Started by JonathanBishop, July 23, 2010, 11:54:24 am

Previous topic - Next topic

JonathanBishop

I'm working on some environments and I'm having some issues with color banding in the atmosphere.  I've done many searches on the forums and tried the suggestions, but still can't figure out what I can do to fix this issue.  Most of the threads I've found refer to the Sample Jitter being less than 1 or the atmosphere samples being too low.  In my file I have gone up to as many as 512 samples and a Sample Jitter of 5 with little to no change in the banding.  I have attached an image of the banding so you can see what I'm working with. 

I would like the haze density and glow to remain at their current settings because I like the look it gives.  The haze density is at 2, the haze glow amount is at 2 and the haze glow power is at 1. 

My cloud samples are also set pretty high at 159 for the volumetric cumulus and 24 for the volumetric altocumulus.  However, since the banding is in the atmosphere and not the actual clouds I don't think this could be an issue.

My render settings are as follows:

Detail 0.8
AA 5
Ray trace objects on
Pixel filter Narrow Cubic
Anti-aliasing bloom (I've tried on and off with very little change)
Microvertex Jittering on
Detail jittering on
Ray traced shadows on
Ray trace everything off (could turning this on maybe help?)

I'm not sure if it matters, but I am also not using any GI in my renders and I'm rendering at 1024x1024.

If anyone has any suggestions I would be greatly appreciative.  I've been working on this issue and doing test renders for a while and would love to get a smooth result.  I've rendered out a dozen other skies with similar settings and this is the only one I've had a problem with.  Thanks in advance!

Oshyan

Strange, my first guess would indeed be that you need to turn up Sample Jitter. But more than 1 is really never needed, and if you've already tried 1 and it still produces this result (does it make *any* difference when you change it?), then we have to look elsewhere. As a troubleshooting measure, try turning on Raytrace Everything and do another render. Does that change things?

- Oshyan

Kadri


Did you tried to save as EXR and then save as PNG or whatever you want in another Photo Editor ?
Does it make any change , JonathanBishop ?

PG

I would also check if this happens while it's rendering or when it's saved.
Figured out how to do clicky signatures

FrankB

good question PG.
An old version of paint.net gave me banding easily when fine-tuning renders, which now doesn't happen anymore since a newer version of paint.net.



JonathanBishop

July 26, 2010, 11:50:16 am #5 Last Edit: July 26, 2010, 01:36:28 pm by JonathanBishop
I just tried a "raytrace everything" render and it still comes out with the banding.  Didn't seem to make any difference at all.

The image I posted was from a saved EXR opened in Photoshop.  I added the text/arrows and saved it out as a PNG.  In the most recent render the banding was visible in the render window even before saving a file.

I also just did another test render with Detail at 1 instead of 0.8, atmosphere samples at 256, and sample jitter at 16.  The results are attached below.

In looking at the render settings, what does Detail Blending do and might it help?  Currently it's set to 0.  Scratch that, I tried it at 1 and there's still banding.

I'm running out of ideas here other than turning off the haze glow completely.  This totally changes the dynamic of the image, though, so I don't consider it a realistic option except as a last resort.


JonathanBishop

As a reference, here is the same scene with Haze Glow set to 0.

JonathanBishop

July 26, 2010, 03:02:11 pm #7 Last Edit: July 26, 2010, 04:23:09 pm by JonathanBishop
Okay, I figured out my issue.  It seems that if Haze Amount is greater than 1, Haze Power must be less than 1 or you get overblown, banded colors.

My previous renders were with Haze Amount at 3 and Haze Power at 1.  The following render is Haze Amount at 3 and Haze Power at 0.75.  As you can see, the banding issue is no longer present and the atmosphere render is smooth.

To get the same general effect as my first renders I was able to go up to Haze Amount of 4 with a Haze Power of 0.9 with no banding and good results.  Anything higher than 0.9 (I tried 0.95 and 0.99) would produce banding.

Oshyan

Nice troubleshooting Jonathan, that's a new one on me. Good to be aware of (and to document, and possibly fix).

- Oshyan