Terrain not rendering at height

Started by nbk2, March 02, 2012, 09:05:03 pm

Previous topic - Next topic

nbk2

March 02, 2012, 09:05:03 pm Last Edit: March 02, 2012, 09:10:13 pm by nbk2
Hi I have the problem that parts of the terrain aren't rendering above a certain height. I have changed whatever I could find and the only thing that gets everything rendered is setting the bucket size >= 1024x1024 and disabling auto adjust. But then in a cruel twist of fate the screen goes black AFTER it rendered everything and also in temp files the file is black.

Same at 2048 and so on.

All other settings fail besides making it maybe worse. raytrace everything leads to even worse terrains.

This happens also at different angles with different heightmaps, different ways of loading heightmaps and so on.

I also increased the sub div cache and preallocated it. Tried to search the forums, but only found release threads.


I also switched off atmosphere.. same result..


wtf.jpg is a screengrab short before it goes black, just to demonstrate that at the right bucket size it renders, just that the screen goes black after it.

I attached the TGD of the simplest scenario I could recreate this feature.

I am on an Intel Core 2 Quad Q6600 (Kentsfield) 4GB Ram and 3GB enabled. 32bit Vista.



freelancah

Did you try increasing the displacement tolerance in the planet node?

nbk2

Quote from: freelancah on March 03, 2012, 12:27:51 pm
Did you try increasing the displacement tolerance in the planet node?


Yes but only to two, the max on the presented scale.

When I changed it to 20 it seems to work at the simple example thanks! :)