Surface Indirect Flashing

Started by dorianvan, September 06, 2013, 01:12:38 pm

Previous topic - Next topic

dorianvan

I rendered my beauty and several elements. I noticed my beauty had a little GI flashing in it, then I viewed just the Surface Indirect (GI + refl.) and very noticeable large-scale flashing is occurring (see attached video). My GI setting were 2/3/8, rendered every 3 frames, and interpolated a blending of 5; Defer Atmo/Cloud is off, Atmosphere samples are 24. I tried a small section at 3/6/10, every 5 frames, blending of 5; and still saw the flashing on the beauty. Any ideas to get rid of the flashing?
-Dorian

Matt

Hi Dorian,

It looks like you'll need to render your GI passes with much higher quality settings, for this scene at least. There might be something about your atmosphere that is casting more variable or contrasted GI onto your landscape, so the simplest solution is to render with higher GI settings.

Try 8/12/8 (Terragen 3 settings, not Terragen 2). This will take a lot longer per pre-pass frame, of course, but, you probably don't need to render every 3rd frame. Every 10th frame might be sufficient. Maybe even every 20th. You could try rendering on 20s, and then only render frames in between if there are problems with the 20s. Rendering sparser GI cache frames also has the advantage of slowing down the rate of the pulsing/fluctuations, which further helps to make the fluctuations less noticeable.

If you still have problems after all that, look at your sky and see if the sky around the sun is abnormally bright - perhaps due to excessive glow factors in the atmosphere or clouds. This is one possible cause of troublesome GI, but I think it's probably still possible to stabilise it using the suggestions I made above, i.e. higher quality GI and more sparse GI frames to reduce the speed of the fluctuations.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

dorianvan

QuoteTry 8/12/8 (Terragen 3 settings, not Terragen 2). This will take a lot longer per pre-pass frame, of course, but, you probably don't need to render every 3rd frame. Every 10th frame might be sufficient.

Thanks for the help Matt. I first tried 6/6/8 and you're right, it took a lot longer; so I'm sure 8/12/8 would have been even longer than that. My 6/6/8 cache was rendered every 7th frame and done at 1080p (over 300MB per file!); on a small 30 frame section, the flicker was gone. The file sizes were too large to do 330 frames. So I went down to 4/6/8 every 10 frames and this time at 540p. The size was much smaller at about 36MB each frame, and it also worked (changing back to 1080p). I might try a little larger section for 4 or 5 seconds to make sure, but thanks again.
-Dorian

Bjur

September 09, 2013, 05:48:13 pm #3 Last Edit: September 09, 2013, 05:50:07 pm by Bjur
Maybe something set just didn't worked like intended but worked as usual the next day or fresh start (had 1-2 problems like that with the 1st versions of TG 3 Free e.g.)..

1st time I saw your example .mov, I was thinking it's a kind of fast forward animation and you may have forgotten own fast moving or changing cloudscapes
or just to turn them off for simple tests. Thus your direct and indirect lighting changes were looking fast but nevertheless constant and very smooth/natural to me..  ;D

I'm curious, final conclusion and solution wise. 
~ The annoying popularity of Vue brought me here.. ~

dorianvan

@Matt. I spoke too soon, my test was only on one computer. When rendering across 6 computers, flashing is still there. Makes me think higher GI settings were not the problem at all, but something else. I do have higher glow amounts (see attached), but I increased the GI to 6/10/8 and there was no reduction in flashing.

I rendered GI (360p) at every 10th frame (for 8 total gic's) and blended every 5 frames, then rendered every frame from 1-50 (1080p). Flashing occurs on the following computers: comp1:fr3, comp2:fr9, comp2:fr10, comp3:fr17, and comp5:fr33

I had also gathered the assets into one folder and copied that folder to the other computers. I'm scratching my head here. What could it be?

@Bjur, nothing is animated except the camera.
-Dorian

Matt

Hi Dorian,

I'm not sure, but here are some ideas which might help.

I see that you have cloud layers in there too, which are potentially a bigger source of GI than your atmosphere and also have their own glow settings.

This new test has a different kind of problem. It looks like it's not smoothly blending between GI files, suggesting some machines are seeing different files.

Did you delete all your old cache files before copying over the new ones? The last thing you want is to have cache files generated with different settings sitting together in the same folder, because when Terragen renders the final frames it will just sweep up any files it finds that match the naming sequence. It has no idea what frame step (cache sparsity) you last rendered and want to use. An alternative to deleting old files (or better yet, do this as well as deleting old files) is to have a version number policy, increment your version number each time you change settings or re-render a sequence, and use that version number somewhere in the filenames of the cache files.

If possible I would render all my cache files to a network drive that all machines can see, and have all projects read the caches from the network drive. That way you can be sure all machines see the exact same files and you avoid a potentially error-prone manual step.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Matt

Quote from: dorianvan on September 11, 2013, 05:50:37 pm
I had also gathered the assets into one folder and copied that folder to the other computers. I'm scratching my head here. What could it be?


I believe the cache file sequences are not dealt with by the Gather Project feature, so you would still need to manually copy all the cache files over. I think the Gather Project window should give a warning about this.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

dorianvan

The only clouds that are on are the atmo and cirrus.
All appears good now. Here's what I did: I created a brand new folder, saved the files through the network there (both caches and finals), lowered the atmo haze density from 3.5 to 3, and raised the haze exp height from 2000 to 2500. The result was a nailed down GI...finally! Thank you Matt for the assistance. Upping the GI I'm sure makes it nicer, but in my case it wasn't the culprit.
-Dorian

Matt

Great :) Thanks for letting us know it's all working now.
Just because milk is white doesn't mean that clouds are made of milk.