Author Topic: Shadow "Pooling"  (Read 2325 times)

Offline JasonArcher

  • Member
  • *
  • Posts: 17
Shadow "Pooling"
« on: September 18, 2013, 10:57:31 PM »
I encountered an odd issue with shadows seeming to rise out of the ground and "pool", for lack of a better word, on a fly-by animation. Has anyone encountered this issue? I currently have ray traced shadows set to on.

I've included a short clip of the first segment of the animation as an attachment to this post. The effect is visible toward the very end of the animation on the surface of the asteroid.


Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13198
  • Holy snagging ducks!
Re: Shadow "Pooling"
« Reply #1 on: September 18, 2013, 11:09:54 PM »
That's definitely an odd effect, but it's hard to say what's going on. It almost looks like clipping of some kind. Is this a TGD that you could share so we could have a look?

- Oshyan

Offline JasonArcher

  • Member
  • *
  • Posts: 17
Re: Shadow "Pooling"
« Reply #2 on: September 18, 2013, 11:59:12 PM »
That's definitely an odd effect, but it's hard to say what's going on. It almost looks like clipping of some kind. Is this a TGD that you could share so we could have a look?

- Oshyan

Certainly. :) File attached -- I appreciate you taking a look.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13198
  • Holy snagging ducks!
Re: Shadow "Pooling"
« Reply #3 on: September 19, 2013, 12:06:17 AM »
Ah. I believe it's because you have "Lock Subdiv to Frame" turned on and set to frame 0. This terrain is too far from where the camera starts to be properly subdivided as needed for this frame to render correctly.

Did you enable that to solve some specific issue? If not, I'd suggest leaving it off.

- Oshyan

Offline JasonArcher

  • Member
  • *
  • Posts: 17
Re: Shadow "Pooling"
« Reply #4 on: September 19, 2013, 12:24:21 AM »
Ah. I believe it's because you have "Lock Subdiv to Frame" turned on and set to frame 0. This terrain is too far from where the camera starts to be properly subdivided as needed for this frame to render correctly.

Did you enable that to solve some specific issue? If not, I'd suggest leaving it off.

- Oshyan

Ah, thank you.. I'll give it a try, though I may have to turn it off to render those frames where the pooling is occurring and then re-enable it if that's possible -- I found that having it off was causing very noticeable shadow popping, though that was in Terragen 2.5... Haven't given it a try in 3 yet.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13198
  • Holy snagging ducks!
Re: Shadow "Pooling"
« Reply #5 on: September 19, 2013, 12:30:23 AM »
It is one possible solution to shadow popping, though certainly not the only one, nor necessarily the best. Have you tried Ray Detail Region Padding?

- Oshyan

Offline JasonArcher

  • Member
  • *
  • Posts: 17
Re: Shadow "Pooling"
« Reply #6 on: September 19, 2013, 12:40:40 AM »
Haven't tried that yet. I'll give it a shot and see if that fixes it.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13198
  • Holy snagging ducks!
Re: Shadow "Pooling"
« Reply #7 on: September 19, 2013, 12:42:14 AM »
Try a value of 0.5 to start.

- Oshyan

Offline JasonArcher

  • Member
  • *
  • Posts: 17
Re: Shadow "Pooling"
« Reply #8 on: September 19, 2013, 02:40:40 AM »
Still seeing some popping at 0.5 -- I'll take it up a a bit farther and see what happens.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13198
  • Holy snagging ducks!
Re: Shadow "Pooling"
« Reply #9 on: September 19, 2013, 02:42:58 AM »
That looks more like a detail issue since it's happening center screen. The ray detail region padding is intended to deal with shadow casting geometry *off* screen. Did you use the Animation Check button on the Renderer Sequence/Output tab? If you've already done that, then increase detail (I know you're trying to save time on the test, but for this kind of issue it's not an accurate representation).

- Oshyan

Offline JasonArcher

  • Member
  • *
  • Posts: 17
Re: Shadow "Pooling"
« Reply #10 on: September 19, 2013, 03:08:09 AM »
So far it looks clean with the detail cranked up -- and I had overlooked doing the animation check.

 

anything