Upgrade to Terragen 3 from XFrog Megabundle?

Started by PabloMack, November 08, 2013, 10:14:05 am

Previous topic - Next topic

PabloMack

I originally purchased TG2 as part of the XFrog Plants Megabundle. Now I would like to upgrade to TG3. I have logged in but your website doesn't seem to want to recognize that I have Terragen 2 + Animation bundled in my previous purchase. It is my understanding that the XFrog Megabundle contains Terragen 2 + Animation and I have been using its features going on three years now. According to the price list page my upgrade should cost $199 but the purchase options show a mere $99 off the retail $699.

Oshyan

Sorry for the late reply. The best approach in situations like this is to email us at support AT planetside.co.uk. We've taken care of this over there.

- Oshyan

PabloMack

Do I need to uninstall TG2 before installing TG3 or will it install side-by-side with TG2 so that I can use either one?

Dune

It installs side by side. You can see what happens during installation. Handy to have an older version at hand.

PabloMack

November 20, 2013, 07:29:12 pm #4 Last Edit: November 20, 2013, 07:51:34 pm by PabloMack
As I always do, I installed TG3 from the Administrator's account so that it will be available to all users. Now I have a strange problem while trying to use the new program when in my non-priviledged account. Even though I can explicitly run TG3 by double-clicking on the new icon that is now on the desktop, if I try to "Open With" a tgd file and navigate to the tgd.exe executable under "Program Files\Planetside\Terragen 3" the Windows 7 file manager doesn't accept it. Only Notepad and Terragen 2 are listed as being programs that can open a tgd file. If I double-click a tgd file, it runs Terragen 2 as before. Should I have installed TG3 under my own account? It works properly from the Administrator's account but I never do anything other than administrator stuff from that account. Both TG2 and TG3 show up under "Open With" while in the Administrator account but only "TG2" shows up while in my normal unpriviledged account.

Dragging and dropping the tgd file onto the new shortcut on the desktop for Terragen 3 doesn't work. A little Empty Set (circle with backslashe through it) appears and nothing happens when I drop it onto the shortcut. If I double-click the shortcut to Terragen 3, though, the program does run but with default settings because no file was loaded.

Oshyan

Right-click a TGD, choose Open With (if you don't have that option, hold down Shift then right-click); then select Choose Default Program, then click Browse at the bottom and find the tgd.exe in the TG3 install directory. It's possible the file associations didn't work due to TG2 already being associated. In general we do recommend *replacing* TG2 with TG3.

- Oshyan

PabloMack

November 20, 2013, 09:10:18 pm #6 Last Edit: November 20, 2013, 09:17:36 pm by PabloMack
That's exaclty what I did. When I'm logged in as Administrator (under who's account I did the install), the "Open With" shows both Terragen 2 and Terragen 3 as options. When I'm in my non-prvileged account (where I do all my work) it only shows Terragen 2 as an option for "Open With". Yet the install did place a shortcut onto the desktop of my non-privileged account for Terragen 3 (64-bit). The problem may be that I installed Terragen 2 under a non-priviledged account while I installed Terragen 3 under the Administrator's account. Still, that shouldn't be a problem.

Non-Privileged: [attach=2]

Administrator: [attach=1]

Matt

I'm not sure why that is. There may be a bug in our installer but I don't see where it is.

If you click Browse and find the executable, does it get added to the list of applications you can open with next time?

Matt
Just because milk is white doesn't mean that clouds are made of milk.

PabloMack

November 20, 2013, 11:31:03 pm #8 Last Edit: November 20, 2013, 11:36:57 pm by PabloMack
Quote from: Matt on November 20, 2013, 10:40:42 pm
If you click Browse and find the executable, does it get added to the list of applications you can open with next time?


No, not even the next time. It lets you navigate to the executable and select it. When you press "Open" the navigation popup goes away and the menu that lists the applications is left unchanged (i.e. the tgd.exe file is not added to the list). Then when you click "Okay" the file is openned with Terragen 2. When I am in the Administator account (from which I did the install) both programs are shown up front on the right-click popup of the file I want to open so I don't have to navigate to find it. As I understand it, what is in the "Users\Public" account folder is applied to all other accounts inasfar as what programs show up in the programs you see navigating from the Start Button. I would presume there is some facility for adding the programs that are available for "Open With" somewhere in that or other directory structure. It may be that the installer only adds it to the account under which the install is done. But a desktop icon is apparently added to "User\Public" so that it appears in the account I use it in (but didn't do the install under).

Matt

November 21, 2013, 12:17:10 am #9 Last Edit: November 21, 2013, 12:21:36 am by Matt
If the problem only occurred at installation time then it might be something we can fix. But since it's not even sticking when you try to do that manually, it seems likely to be an issue at the Windows level and beyond our control. Perhaps we could force TG2 to be uninstalled first, but I don't think we want that. Or perhaps if the installer could remove the TG2 file associations (for all users) before making TG3 ones, maybe that would solve the issue. I don't know if that's feasible though.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

PabloMack

November 21, 2013, 03:58:52 pm #10 Last Edit: November 21, 2013, 04:30:00 pm by PabloMack
I am going to uninstall TG3 and reinstall it under my non-privileged account. I'll let you know how it goes.

-------- LATER -------
I uninstalled Terragen 3 from Administrator account. Then I installed it for everyone in my unpriviledged account. Problem still there.
I uninstalled Terragen 3 from my unpriviledged account. I noticed that I had two versions of Terragen 2 installed (2.5.4 & 2.5.5). Then I uninstalled version TG2 2.5.4. Then I installed TG3 in Administrator account. Problem still there.
I then uninstalled TG3 and TG2. All TG installations gone. I then installed TG3 in Administator account. Problem still there.
I then uninstalled TG3 from Admin account. Then I installed TG3 "only for me" in my non-privileged account. TG3 is now associated with tgd files and they open correctly when double clicking tgd files.

I seem to remember having the same problem with TG2. I recall it only working when installing it in my unprivileged account.

Matt

Just because milk is white doesn't mean that clouds are made of milk.

PabloMack