Author Topic: Shadow pop  (Read 2076 times)

Offline dorianvan

  • Member
  • *
  • Posts: 391
    • Vandegrift Renderings
Shadow pop
« on: January 21, 2014, 08:14:55 AM »
Hi, does anybody have an idea how to fix this shadow popping in the corner?
Rendered across a network, I rendered an every 10 frame cache, blending every 5 frames. Detail .65, AA7
AA bloom is checked, detail blending 1, jitterings are off
Detail in camera, ray-detail padding 2, prepass padding .5
Render subd - force all edges, ray detail mult .25, stabilize ray det in motion, amount of 3
Thanks.
-Dorian

Offline dorianvan

  • Member
  • *
  • Posts: 391
    • Vandegrift Renderings
Re: Shadow pop
« Reply #1 on: January 22, 2014, 03:11:57 AM »
So one thing that got rid of it on the testing areas is to uncheck Stabilise ray detail in motion in the Render subdiv settings, then in the Extra tab check Lock subdiv to frame...I chose a middle frame number here. There is a some camera movement, but not a lot; the small cropped renders looked good. I'm not too sure of what the downside of using the Lock subdiv to frame is, but I suppose I'll find out in a few days if doing it negatively effected my full-shot animation or not. I'll have to study up some on the Lock, but if anyone has any info on it, I'd appreciate the link or info.
-Dorian

Offline Bjur

  • Member
  • *
  • Posts: 295
  • Fly safe!
Re: Shadow pop
« Reply #2 on: January 24, 2014, 07:00:29 PM »
Hi Dorian.

I never used prepass padding, no need till yet for any animations.

Detail region padding @ 2 is very high (or did you mean 0.2 ? ). Never got any problems with a value of 1.

Stabilize ray detail in motion seems to be cursed ATM. Was never using it because it resulted in much more render time and caused bright little pixels/pixelgroups in the
shadows of a frame for me. I tried a high ray detail multi and fully adaptive on/off, nothing helped. Otherwise your animation should look good without stabilize checked.

Try to render every 5th frame as GI cache if you blend 5 frames (so 1, 6, 11, etc..), not every 10th cache frame for blending every 5th frame.

It ads a little render time, but I won't go under 0.7 again for the ray detail multiplier setting. The overall picture quality is much better.
You should clearly a the difference if you compare one of your 0.25 frame with the same frame with 0.7 (OK, this may depending on your scene).

My 2 cents, good luck!  :)


~ The annoying popularity of Vue brought me here.. ~

Offline dorianvan

  • Member
  • *
  • Posts: 391
    • Vandegrift Renderings
Re: Shadow pop
« Reply #3 on: January 25, 2014, 05:39:02 PM »
Thanks for responding Bjur,
Yes, I meant 2.0; I was really trying to nail it down, but I was climbing the wrong tree there :) I never did try rendering just with Stabilise unchecked; last time I had this problem, I think Matt suggested I uncheck stabilize and check lock frame. Not sure why the combo though, I never got an answer. But aside that, for my semi-minor camera movement, it worked just fine, no popping and very stable. Next time, I'll have to try just unchecking the stabilize. Thanks again.
-Dorian

Offline Matt

  • Planetside Staff
  • *
  • Posts: 3578
  • I'm the crazy one
Re: Shadow pop
« Reply #4 on: January 27, 2014, 10:08:27 PM »
"Lock subdiv to frame" is the simplest way to prevent popping shadows because it locks (freezes) the set of micropolygons being used to cast shadows for the whole animation. You choose a frame number that you think best represents the view of the terrain that will be visible throughout the animation (this might just be a frame somewhere near the middle). The renderer then looks at where the camera is on that frame number and uses that camera to subdivide the terrain to generate the shadow-casting micropolygons. Now, for every frame the shadow-casting polygons will be identical, eliminating one of the causes of popping shadows.

However, it has the drawback that the shadow detail is optimal only when the render is of a similar viewpoint to the frame being locked to. If you render parts of the terrain that aren't visible in the locked-to frame you may lose detail in the shadows or have large areas of false-positive or false-negative shadows, but this can often be mitigated by using the "ray detail region" and/or "ray detail region padding" settings. They change the frustum used to generate the shadow-casting micropolygons. Nevertheless, if the camera moves a great distance away from its position on the locked-to frame the renderer might make suboptimal choices about the level of detail of the shadows, possibly leading to longer render times if there is too much detail in some areas, or it might render too low detail if you move closer to the terrain than the locked frame.

If your camera doesn't move very far, "lock subdiv to frame" should usually work, possibly combined with some ray detail region padding.

If you're using "lock subdiv frame" you shouldn't need to use "stabilise ray detail" because it's designed to blend between different levels of detail. If "lock subdiv to frame" is enabled, there is only one level of detail, and enabling "stabilise ray detail" will only make the renderer do extra work to try to blend between the multiple levels of detail that are exactly the same. "Stabilise ray detail" has problems of its own, sometimes causing a cross-hatch appearance in the shadows and reducing overall apparent detail in the shadows, and it can't stabilise some shadows originating from outside the ray detail region (whereas "lock subdiv to frame" does this). But it's a tool that can be helpful in situations where the camera moves too much to use "lock subdiv to frame".

Matt
« Last Edit: January 27, 2014, 10:23:34 PM by Matt »
Just because milk is white doesn't mean that clouds are made of milk.

Offline dorianvan

  • Member
  • *
  • Posts: 391
    • Vandegrift Renderings
Re: Shadow pop
« Reply #5 on: January 29, 2014, 05:32:08 PM »
Very helpful explanation Matt, thank you.
-Dorian