Resolution mismatch

Started by N-drju, March 31, 2014, 01:52:01 am

Previous topic - Next topic

N-drju

Morning

Yesterday I was trying to do a final render of my scene and set resolution to 1585 x 1151 or so. I usually do my renders in small bits and then stich them back together. However this time when I made the first "row" it turned out that my final render will have dimensions of about 1280 x 850. ??? The size of the render window was set to 100%.

I'm not sure why is that but are there any settings in the render tab that can mess this up? Halp!
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

Oshyan

Nothing I can think of, unless you used Undo or something. And we've had no other reports of such things.

How are you saving the finished image? The render window being at 100% does *not* make the entire window the size of your render resolution...

- Oshyan

N-drju

Oh... then I think this is the problem. So, what makes?

Sometimes when I do these small stiches I have to make a regular screenshot to save it, because the "save" button does not appear. :( Until now it worked just perfect. I thought of this solution due to memory issues that plague me in very complicated renders (right now I'm fighting with eleven populations).

Do you think changing the monitor resolution could help? In the render window I get something like "reduced size" but why since I don't want it? >:(
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

Oshyan

Never, ever use a screenshot! It is NOT accurate to the final render. If the Save button is not appearing, it's still finishing the render, and the screenshot will be even less accurate. It may be a bug, it may just be high render settings, or some slow component. But regardless using a screenshot doesn't really solve the problem, it's just a poor workaround.

- Oshyan

N-drju

Well, how am I supposed to do it then? :P The save button does not appear under any circumstances long after the image in the preview window starts rendering - something TG would definitely do after the render is considered finished...

Once again - if I increase my monitor resolution is that going to help? Logically that would eliminate the need to "reduce size" as my render window puts it. :P
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

Oshyan

No, it won't help. The image in the preview is pretty much never what you want it to be. It's a preview.

You're saying "the save button does not appear long after the image in the preview *starts* rendering". Did you mean *stops* rendering?

- Oshyan

N-drju

No, no, see I meant the window on your working space (3d preview window?) the one above the node network view where you prepare the scene. Usually when you finish render it starts pre-rendering like rendering...10, rendering...20 etc. So, that happens after TG completes the stitch but I could wait forever for the "save" button to appear.

The largest image that I can think of I could do without this auto-reducing nonsense was 1385x915.

I can't see much difference between "screenshotted" and saved stiches. Really! ;)
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

Hannes

May I ask you, why you are stitching small crops together? I used to do this before I had purchased a license for the full version. I assume you are not using the free version, since you're starting a render at a resolution of 1585 x 1151, which is not possible with the test version as far as I remember?! Correct me if I'm wrong.

Anyway, there might be something wrong with the scene if the "save" button doesn't appear.

N-drju

Yes, I do use full version. Well, why did you do that? ;) I have to do it because when I try to render large areas of the would-be final render I get lots of errors like in the thread here:

http://www.planetside.co.uk/forums/index.php/topic,17719.msg171644.html#msg171644

When I do crop region and render smaller bits I get no errors and they render just as I want them to. Sadly, I have no choice.

What might be wrong with the scene itself in your opinion?
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

Hannes

Well actually I didn't render "crops" with the free version, but stitched some 800 px renders made with the free version together to get one single high resolution render. Which was a pain in the ass!

I have no idea what could be wrong with your file. Usually when a render is finished the buttons at the top of the render view window switch from "Pause/Stop" and "Rendering..." to "Render/Save" and "Finished rendering...".

You were talking about these render errors. I remember that I had those as well some time ago, but I can't recall exactly when at the moment. I'll have to look for this thread.

Hannes

It was this thread:
http://forums.planetside.co.uk/index.php?topic=8144.0

The final image was here:
http://www.planetside.co.uk/forums/index.php/topic,8182.msg87194.html#msg87194

Unfortunately I still don't know why these artifacts had appeared. As you can read I just used another render thread with almost identical settings like in the original one and everything worked fine. ???

N-drju

Courage and heart can overcome the machine...

Oshyan, it looks like you were wrong. Probably for the first time ever on this forum. ;) I actually changed my monitor resolution to the highest value (2048x1536 or so) and my render window showed up in exactly the size I planned for (1644x1196) without auto-reducing. As luck would have it the stubborn "save" button does not appear no matter what so I'll just stick to my crappy "print screen" technique thank you. ;D

Hannes, your solution as far as render errors are concerned, sadly, did not work. :( Guess I've just got way too much objects in the render for the program to work seamlessly.
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

Kadri

April 01, 2014, 02:19:24 am #12 Last Edit: April 01, 2014, 02:21:48 am by Kadri

Have you looked in the "Sequence/Output" tab in the render node for saving the images?
And there is another option in the Edit menu in the
"Preferences",  "File Saving" section for automatic render output and path option.
Not sure if this will help if the "Save" button doesn't appear.

Dune

If the save button doesn't appear, it's probably not done yet, but you might have a look. I've had this a few years back, and think it might be memory related. I had lots of unrendered blocks then too.

Kadri

Quote from: Dune on April 01, 2014, 03:32:07 am
If the save button doesn't appear, it's probably not done yet, but you might have a look. ...


I doubt it too Ulco. But just in case.

On the other thread i saw that you use Bucket sizes with 64.
Not sure if you tried them because of your problems but in my own tests
with different scenes render times don't go faster after 128 or so.
And actually with Bucket sizes of 64 render times takes longer.