Problem with my dunes

Started by wiwine, June 23, 2014, 08:28:42 AM

Previous topic - Next topic

wiwine

Hello.

I'm still working on the 2nd part of my "Dunes & sandwaves" tutorial and I've got a problem.
As you can see on the two following renders, there are many dark spots that appear on the dunes at medium or long range.
I don't know where they come from, nothing in the process can explain this.
The problem appears mainly when the sun is low.
If I move the POV, the dark spots disappear and appear somewhere else. For example, if I render these areas at short range, there is no dark spot...
I tried to change many parameters (light, atmospherics, overall quality, etc.) but I can not rid off these spots.
You can find the .tgd files below.

Can you help me ?  :-\

[attachimg=1][attachimg=2]

N-drju

Did you try to increase AA or resolution?

If this is Curiosity imagery these spots might be Martians... :P Just kidding. ;)
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

Oshyan

What you need to do here is go into the internal nodes of the Renderer node (open the Renderer node's settings and click the Gear icon in the upper-right and view internal network). Then find the Render Subdiv Settings node (it may be hidden under another node, so move them around). In the settings for that node, turn off Fully Adaptive and turn on Force All Edges. That should fix a majority of the problems in this case. And Detail of 0.92 should not then be required for good quality, 0.5 is adequate. Note however that these settings are *not* necessarily recommended in a general sense, and may not work ideally in some scenes or circumstances (which is why they are not set that way by default). They also affect render time.

- Oshyan

Tangled-Universe

Disable Fully Adaptive will do the trick.

Tangled-Universe

Ah Oshyan beat me :)

I didn't need "force all edges" though to make it work...

Oshyan

Force All Edges cleans up some other little render issues in this particular case (from what I saw in my tests).

- Oshyan

wiwine

Thank you very much for your tips !  :D The first test is successfull.
I didn't even know these "fully adaptative" and "force all edges" parameters...   ???
(and for the moment, I don't understand what they mean)

wiwine

I realize that these parameters solve some problems I had for a long time... this solution works even at small scale (sandripples).
Is there any documentation that explain what these parameters do ?

Oshyan

At present these settings are quite advanced and not exposed visibly in the render node for this reason (though they can be found, as you've seen). We are still tuning some of these controls for ideal default settings. No public documentation is available at this time, but we will document them as soon as possible, especially if they become necessary to use regularly.

- Oshyan

Oshyan

Those sand ripples look great by the way. Care to share a TGD for those too? ;)

- Oshyan

wiwine

The sand ripples are still a WIP... different presets will be available soon, with the second part of my tutorial  ;)

DannyG

New World Digital Art
www.NwdaGroup.com
Media: facebook|Twitter|Instagram

Shigawire

You are the best Wiwine :D Glad the guys helped you.

Sandwave ripples look insanely good

bobbystahr

Quote from: Oshyan on June 23, 2014, 05:20:01 PM
What you need to do here is go into the internal nodes of the Renderer node (open the Renderer node's settings and click the Gear icon in the upper-right and view internal network). Then find the Render Subdiv Settings node (it may be hidden under another node, so move them around). In the settings for that node, turn off Fully Adaptive and turn on Force All Edges. That should fix a majority of the problems in this case. And Detail of 0.92 should not then be required for good quality, 0.5 is adequate. Note however that these settings are *not* necessarily recommended in a general sense, and may not work ideally in some scenes or circumstances (which is why they are not set that way by default). They also affect render time.

- Oshyan

Having a senior's moment here....when I click the gear then view internal network in the render node dialogue all I get is open space in the nod network area...what am I doing wrong? I see no hint of what you describe.
something borrowed,
something Blue.
Ring out the Old.
Bring in the New
Bobby Stahr, Paracosmologist

Dune

Rightclick on the rendernode, then click internal network and you're inside (it's not always that easy  :P ); then you should see three nodes, the fourth is underneath the bottom one, so as Oshyan says, move that aside.