Author Topic: Heightmap is cut off  (Read 1350 times)

Offline Abyssinian02

  • Member
  • *
  • Posts: 24
Heightmap is cut off
« on: January 25, 2015, 03:29:50 PM »
I'm working on a new map and I just noticed that my heightmap is cut off at the bottom, as well as the top. It would appear that the landscape is slightly lowered near there and that's why it falls into the ocean. Would anyone have a tip against that? I'd like to remain in full control over my heightmap, and not have the edges trail off downwards.

BTW, the heightmap is a WIP and is only 1 color of grey for now.

Offline Dune

  • Member
  • *
  • Posts: 15131
    • www.ulco-art.nl
Re: Heightmap is cut off
« Reply #1 on: January 25, 2015, 03:33:28 PM »
I don't think that would be a problem if you project your image map in Y direction onto the planet, and the ocean is a lake or sphere, so I wouldn't know what caused it. How do you apply the heights?

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13116
  • Holy snagging ducks!
Re: Heightmap is cut off
« Reply #2 on: January 26, 2015, 05:05:34 AM »
Indeed, really need to know more about exactly what you're doing here. What format is the source map, what node(s) are you using to load and apply it, what projection are you using, what other shaders/nodes are in the scene (e.g. Lake)?

- Oshyan

Offline Abyssinian02

  • Member
  • *
  • Posts: 24
Re: Heightmap is cut off
« Reply #3 on: January 30, 2015, 12:58:48 PM »
The map is a tiff file, 6200x5000 and only shows this weird situation at the top and bottom because they're close to the edge. I'm using a basic heightfield shader that loads it, and a very small smoother to take off the very very rough edges.
« Last Edit: January 30, 2015, 01:00:55 PM by Abyssinian02 »

Offline Dune

  • Member
  • *
  • Posts: 15131
    • www.ulco-art.nl
Re: Heightmap is cut off
« Reply #4 on: January 30, 2015, 02:50:30 PM »
If it's a grey scale tiff, why not use the internal displacement tab in the image map shader? The heightfield shader may be the problem.

Offline Kadri

  • Member
  • *
  • Posts: 8502
Re: Heightmap is cut off
« Reply #5 on: January 30, 2015, 03:45:12 PM »

Do you need border blending? Without border blending there is no cut off.
Look in the "Heightfield shader 01" node "Border blending" option and use zero.
« Last Edit: January 30, 2015, 05:12:50 PM by Kadri »

Offline Abyssinian02

  • Member
  • *
  • Posts: 24
Re: Heightmap is cut off
« Reply #6 on: February 10, 2015, 03:25:17 PM »
It was the border blending that caused the problem. Thanks Kadri for the solution!!