Beta 4-Render bucket artifacts

Started by yossam, July 18, 2016, 02:29:36 pm

Previous topic - Next topic

yossam

About 75% done on a render in its 16th hour and I'm getting bucket artifacts............anyone else experienced this? Pic is 3600X2400, quality is .5, AA 8. I can't post the file............it's one of Lucs'.  :-\

Stormlord

July 18, 2016, 03:43:55 pm #1 Last Edit: July 18, 2016, 03:50:41 pm by Stormlord
Once I had the same Problem with 3dsMax while rendering a very big picture for a print.
The Problem is insufficient memory. To save a picture in his memory internaly (while he renders it), the computer need the memory for the whole rendering in one single block.
If the memory which is available in your computer is fragmented (not as a single blockavailable) it runs into problems, it has no idea where to put his rendered data in his memory and therefore it leaves the pixels simply black. That's why  and this should help to understand where the cause of your problem is... I hope, I could help you to understand your problem :-)

The Problem - > The Dimensions are to great for your memory inside your PC or another program uses memory or another program is running which uses also memory, ect...
The Solution -> Crop the picture and split it into 2 or more areas (depending on your size) and merge it in your postwork with Poposhop...

my best

STORMLORD

yossam

I doubt very seriously it is a memory problem..........the computer has 64 GB. Usage was around 25 GB according to the chart. It looks like the GI problem that pops up occasionally, but it is at default for the render pass.  ;) 

Oshyan

Can you post a screenshot of the render-in-progress, for a start? Render bucket errors can occur for various reasons and we may be able to tell just by looking at it what the culprit might be.

- Oshyan

yossam

Here you go Oshyan, right below the plane nose. It goes all the way across the pic.

Oshyan

Wow, gorgeous clouds. Did you enable the cloud Acceleration Cache at all? It usually defaults to off (None) with the new v3 clouds and it can cause these kinds of errors.

- Oshyan

yossam

No I did not.............didn't know I needed to.  :-\


I agree about the clouds.........they are Lucs'.  :)

yossam

You are talking about under the Optimisation tab.............I have never changed that, ever. What setting do you recommend?  :o

ajcgi

I've only played with that setting in the past fortnight, trying to bash previs out faster. Optimal seems... optimal.  :o
Though I did get a similar thing with acceleration cache set to anything less than none.
Another thing that falls foul of it can be the reflection shader. Naturally that isn't on your clouds, but as a similar fix, perhaps try expanding the raytrace padding.

[Edit] another thing I found fixed it on reflections was to lower the samples all the way to 1 bizarrely enough.

Oshyan

I think you may have misunderstood. I was saying that you should *not* have changed that setting, that it should remain set to "None (Highest Detail)". If that's still where it's at for all of your cloud layers then the culprit must be something else. I'll see if I can think of other possibilities, but seeing your TGD would help.

Alex, the reflection shader doesn't handle softness that well across bucket boundaries. So if you have any softness, it requires very high numbers of samples to resolve well. The softness values are also extremely sensitive, you want to use very low point values in general.

- Oshyan

yossam

Quote from: Oshyan on July 18, 2016, 04:46:38 pm
Wow, gorgeous clouds. Did you enable the cloud Acceleration Cache at all? It usually defaults to off (None) with the new v3 clouds and it can cause these kinds of errors.

- Oshyan



The way I took this was the way you said it..............anyway, I think maybe I know what may have caused it. I just don't know why. I put the render on pause for about 2 hours at that point. I started it back before I went to bed and found the artifacts the next morning. I almost looks like the GI changed for some reason. There is a difference in the lighting that you can see in the pic.


I have another render going with conservative acceleration, and there are no artifacts. I haven't paused that render either and I'm not going to.

Oshyan

Hmm, so... I'm still not clear on what your Acceleration Cache setting was in the original render. :D I would recommend setting it to *None*, for now. Conservative may improve things if it was set to "Optimal", but for v3 (new in Terragen 4) clouds it's best to use None for now.

- Oshyan

yossam

It was on none. As I said before, I have never changed that. It has always been on none, even before the beta.  ;D

Oshyan

So then you *increased* it? Hmm. Well, ok. I guess the proof will be in the pudding, so to speak.

I can't really think of why pausing the render would cause the issue, unless the new v3 cloud GI system doesn't keep its state during pausing. It should, of course. I'll check with Matt and see if he has any ideas.

- Oshyan

Dune

This has not very much to do with your case, Richard, but pausing and doing something else may cause trouble. I had a render paused yesterday, opened Photoshop to do something, closed it again and wanted to resume rendering. But TG had crashed in that moment. Probably memory related, I guess.