Classic Erosion plugin

Started by Daniil, November 03, 2017, 05:14:19 am

Previous topic - Next topic

mhaze

Ok I've found the problem.

icarus51

All Right Daniil. Yes, i referred to DKerosion but now all is working. There are others problems with new Update, not from your files.   :)
Regards.

WAS

@blinkfrog  will this plugin get a Linux release to use with the Render Node?

WAS

There seems to be a problem with eroding a merged terrain, where it seems to be eroding only one of the mixed terrains.

PS @Matt, or @Kevin Kipper I think this topic should be pinned along with the procedural plugin. I had to search for it.

Dune

I can't imagine it does that. Did you try with say 2 simple shapes?

WAS

No, im not sure how that relates to texture space merging.

It could be because of rivers mode. Beyond flows there seems to be no rivers into any valley. It only seems to be eroding the rough mixed terrain, not the valleys with fat less disp. Just flattens it out.

Dune

I mean 2 simple terrains, so you can more easily see what's happening. You can't see it in your screenshot.

Valri

I've been out of the loop for a while, but has a fix been found for Daniil Kamperov's Classic Erosion plugin yet?
Put that in your pipeline and smoke it!

WAS

Quote from: Valri on January 27, 2021, 09:51:23 pmI've been out of the loop for a while, but has a fix been found for Daniil Kamperov's Classic Erosion plugin yet?
Do you mean an update for the incompatibility with latest versions? Then yes.

WAS

One thing I noticed, but I'm not sure can be remedied is the shader doesn't recognized disabled nodes, and won't re-erode. You gotta delete/unplug said diabled sahders.

fenwick

Where should I install the classic erosion file ?
Thanks Fenwick

WAS

Terragen installation folder, in the Plugins folder.

Alvin R.F.

Is there a walkthrough of how to install the plugin I am new to this? I watched the youtube tutorial and found it helpful but was stuck at the park of downloading and installing the plugin. It did not immediately populate when I went in to add Terrain > Displacement Shader.... 

Any help or guidance is greatly appreciated.

Thanks.

Dune

Did you add the erosion plugin in the main line of nodes after the terrain fractal? Otherwise post the tgd you worked on, and one of us can see what you did wrong.

WAS

June 05, 2021, 01:15:41 pm #224 Last Edit: June 05, 2021, 05:34:30 pm by WAS
You need to put the dkclassicerosion.tgp into C:\Program Files\Planetside Software\Terragen 4\Plugins folder, or wherever you installed Terragen to.

Then restart Terragen and it will show up under the following:

Terrain -> Add Terrain -> Dispalcement Shader -> (Danill Kamperov) Classic Erosion
Right-Click in Node Network -> Create Shader -> Displacement Shader -> (Danill Kamperov) Classic Erosion
Hit Tab to open Node Palette -> Search "Classic" or select the "Shader > Displacement" category; then select (Danill Kamperov) Classic Erosion