Fading White Peaks on Water

Started by WAS, May 15, 2018, 06:55:24 pm

Previous topic - Next topic

WAS

May 15, 2018, 06:55:24 pm Last Edit: May 15, 2018, 06:58:27 pm by WASasquatch
I'm trying to create white peaks, but I'm not sure why the fuzzy zone doesn't work when constructing the white peaks. No matter the feature, the cut-off is a solid line, unlike when it's used on normal terrain. I tried adding even a dark surface layer before the white peaks with a colour enabled and set to a dark colour, but there is still not fuzzy zone when messing with the parameters.

Additionally, you can't seem to preview the surface layer results. It shows nothing, not even the test colour, though it is there in preview and render.

Matt

May 15, 2018, 06:57:20 pm #1 Last Edit: May 15, 2018, 06:59:02 pm by Matt
In your whitecaps shader's "Altitude key" try "final position" rather than "position in terrain/texture". Alternatively, add a Compute Terrain or Tex Coords from XYZ before the whitecaps shader.

EDIT: Hmm.. actually I don't see why that would cause this to happen. Can you tell us more about your setup?

Matt
Just because milk is white doesn't mean that clouds are made of milk.

WAS

May 15, 2018, 06:59:24 pm #2 Last Edit: May 15, 2018, 07:09:20 pm by WASasquatch
Quote from: Matt on May 15, 2018, 06:57:20 pm
In your whitecaps shader's "Altitude key" try "final position" rather than "position in terrain/texture". Alternatively, add a Compute Terrain or Tex Coords from XYZ before the whitecaps shader.

Matt


I'm on final position. Tried a computer terrain, though not sure why I didn't try a normal. Will try a normal and tex coords from xyz now. Also added some additional information.

Edit: Well I just crashed TG trying to under one step without saving haha, I'll rebuild and hopefully not have this issue, but if it's still there will upload TGD.

Edit 2: Already through rebuilding it doesn't seem the preview issue is present, and their appears to be a definite fade. Huh

WAS

Yeah didn't encounter either problem with the rebuild. Which is just a clip file with the added surface layer. Odd.

Looks decent, needs lots of work. Namely the bubble mask for the seafoam colour seems to be causing anomalies at lower altitudes where it should be cut off from altitude constraints. There is no vanilla water displacement here, all from custom displacement.