Is this a bug?

Started by Kadri, June 05, 2018, 09:34:59 am

Previous topic - Next topic

Kadri

June 05, 2018, 09:34:59 am Last Edit: June 05, 2018, 10:34:18 am by Kadri

With the "Plane 02"object enabled you get the problematic edges on the rocks that are in front of dark background.
It looks like the problem is mostly the luminosity in the plane object behind the rocks and cloud.
But even without luminosity there are still some parts that are problematic.

Years ago the rock object was said to be a problem itself. Is it because of the rock object itself?


KlausK

hi, though I can only see the rocks BECAUSE of the gray fringe ;) I gave it a try.
No idea why it happens. CHeers, Klaus.
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

Kadri


LOL yeah, looks like that gets rid of the edge brightness :)
But we shouldn't have to do this. Not sure if there are other things that i used-changed that affects this.

I tried it with a standard planet object and it is still problematic (with raytrace on).
Not a rock specific problem probably.

I am testing one with raytrace off Klaus.

Dune

Maybe the mesh displacer breaks the seams, which lets light through.

Kadri


Wow rendering without raytrace objects is SLOOOW :)

Ulco the planet object does have that problem too.

Kadri

June 05, 2018, 11:45:34 am #5 Last Edit: June 05, 2018, 12:01:17 pm by Kadri
Render finished. Raytrace object OFF still problematic.



This is with Windows 10 64 bit, Terragen 4.1.21. professional.

Kadri

June 05, 2018, 12:11:14 pm #6 Last Edit: June 05, 2018, 12:19:33 pm by Kadri

Interesting, Klaus i still get the problematic edges, even with force ray trace or with the other options.
Are you sure you haven't changed any other settings?

Kadri


"Defer atmo/clouds" OFF got rid of those edges.
Klaus have you changed that maybe in your test?

Anyway this is less of a problem if this is the solution.
Would be good of course if others test it too.

WAS

Can you try removing the luminous plane which will have serious issues with lighting that I've been pointing out, and try a light source surrounded by a V2 cloud with no density to create your solid glow?  Luminous surfaces create grain lighting in clouds and surfaces, which could also not interact properly with 3D objects when viewing them from behind.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Kadri


Thanks Jordan. I am rendering the scene in layers so no problem with the objects Lighting.
As i said i tried (as you said above) some other ways but other parts changed too much. This got the most look i liked.
Not sure about grain. Maybe with morphing and postwork it might still work.
Will see what happens. Maybe this will be just another test :)

KlausK

Kadri,
Quote"Defer atmo/clouds" OFF got rid of those edges.
Klaus have you changed that maybe in your test?

QuoteInteresting, Klaus i still get the problematic edges, even with force ray trace or with the other options.
Are you sure you haven't changed any other settings?


I did not change anything except for the "Plane" objects Render Method (I think...).
But see & try for yourself.
CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

Matt

It might be related to this:

https://planetside.co.uk/forums/index.php/topic,17307.msg168118.html#msg168118

What's weird, though, is that in your scene you see a problem when Defer Atmo/Cloud is ON, whereas in the other scene I linked to there's only a problem when Defer Atmo/Cloud if OFF. They might be two different bugs or they might be the same one but apparent in different conditions - I don't know which yet.

In both cases, using Max Samples instead of Adaptive Sampling appears to fix it. But in your scene the best solution is to Force Ray Trace on the Plane. If you're not displacing the plane, this is probably the highest quality and most efficient way to render the plane anyway.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Kadri


Thanks Klaus. Searching for bugs when you are sleepy isn't bug free too i suppose (double sorry :) )
I read it as force raytrace in the rock objects when i should have tested it in the plane object...duh!

Thanks Matt. I remember that thread now. It is rare as you said probably. I have seen it the first time myself.
I tried many other settings just to narrow it more to be helpful but it was just those settings that made the difference in my tests.
Using "force raytrace" on the plane, "Defer Atmo/Cloud" OFF and using "Max Samples".
Using force raytrace is better as you said in this scene.
Using lower  "Pixel noise threshold" gets rid of those edges too gradually. "0.03" looked OK to me.
But that setting is related to "Max Samples" anyway i think?