Author Topic: GUI "Objects" tab list - click-selecting items sooner or later crashes TG 4.4.18  (Read 99 times)

Offline KlausK

  • Member
  • *
  • Posts: 462
  • Land ho!
Hi everyone.

I am experincing this strange behaviour on my newly installed copy of Frontier TG 4.4.18.
GUI "Objects" tab list - click-selecting items sooner or later crashes TG 4.4.18.
Description is in the picture. There is the gathered project zipped up to try for yourself.
In there is the imported asset I used. A *.obj I made.
Anybody ever faced problems like this?

Thanks for taking a look and comments.

CHeers, Klaus
« Last Edit: July 08, 2019, 11:39:40 AM by KlausK »
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

Offline jaf

  • Member
  • *
  • Posts: 785
Klaus -- How long (how many tries) does it take to get the crash?  Do you have to click each quickly?

I haven't been able to get a crash.

I notice in your image file, the node network is at it's highest (Planet 01 displayed instead of the Objects node.)  Is this simply from putting the image together to show the workflow or does it "jump" to that when the crash occurs?
« Last Edit: July 08, 2019, 01:39:03 PM by jaf »
(10jul19) Ryzen 1800x, 970 EVO 1TB NVME-M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 431.36 (10jul19), Win 10 Pro x64, Terragen Frontier 4.4.18 BMark 0:10:18

Offline KlausK

  • Member
  • *
  • Posts: 462
  • Land ho!
Thank you, jaf for taking a look.

I can crash the scene within 10-15 clicks on the item in the left window. And no, I don`t think I click-select very fast.
But I think that because you are not able to reproduce the crash this might be a glitch on my machine.
Perhaps the drivers of the Nvidia card. There are other glitches that seem strange while using the this computer.
This is a very old, badly maintained installation of Win7 I fear...with lots of installs and uninstalls over a long period of time.

It`s simply a pain in the a** to do a fresh install of the system which has gathered so much "dust" over the years.
But looks like it is about time...sigh. Probably I`ll get a new harddrive and start from there.

If I notice anything else coping with this problem I`ll post it here.

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 13182
  • Holy snagging ducks!
I can't reproduce this here either. The pattern of the issue on your system strongly suggests a graphics driver problem. The reason I say that is that those icons you're describing that seem to cause the crash when you click on them, those all invoke the *mini* 3D preview with geometry that has to be rendered by your graphics card. So what you're doing when you click between them is repeatedly telling your GPU to load and display a 3D object. This is for some reason a classic source of possible driver-related issues in Terragen 3D preview modes. Usually it starts to happen after some driver update from the manufacturer inadvertently breaks something, and it's usually fixed in a later release.

Anyway, to test my theory you can click the small blue square icon with a white+gray outline at the top-right of the node list. That will disable the mini object 3D preview for this session. If you can then click around in the list without crashes, then it's probably a driver issue, unfortunately. Reformatting *may* help, but also just try updating or doing a clean reinstall of your drivers.

- Oshyan

Offline KlausK

  • Member
  • *
  • Posts: 462
  • Land ho!
Thank you for the information, Oshyan.
Turning off the Preview as you described seems to help.
So i will perform a clean un-install with Display Driver Uninstaller and then re-install the drivers for the Nvidia card.

CHeers, Klaus

/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

 

anything