Export Terragen terrains as vector displacement map

Started by james adamson, January 03, 2020, 03:15:38 pm

Previous topic - Next topic

james adamson

Hi all. I have been going through digital gurus tut on this and am having some trouble getting results in Modo using vector displace.
Has anyone got this working in Modo. I guess it should work in any software that has the ability to do vector displacements so must be doing something wrong.
Im just not sure what. I have rendered out the vector image as 32 bit exr. Image is 4096x4096. I made an 8kmx8km plane in modo added the vector image to 
my materials group and set its effect to vector displace. My plane was multi res 8. The displacement is nothing like what was expected.
Anyone got any ideas this technique could save me days and days.
Cheers.
James.

paq

Could you maybe post what's your result ?, because just plain text is hard to troubleshot.
Common problem with this kind of export is vector orientation. You might need to switch some channels (r to g, r to b), or invert some of them.
Gameloft

WAS

Quote from: James Adamson on January 03, 2020, 03:15:38 pmHi all. I have been going through digital gurus tut on this and am having some trouble getting results in Modo using vector displace.
Has anyone got this working in Modo. I guess it should work in any software that has the ability to do vector displacements so must be doing something wrong.
Im just not sure what. I have rendered out the vector image as 32 bit exr. Image is 4096x4096. I made an 8kmx8km plane in modo added the vector image to
my materials group and set its effect to vector displace. My plane was multi res 8. The displacement is nothing like what was expected.
Anyone got any ideas this technique could save me days and days.
Cheers.
James.

Did you do an orthographic topical render? You also don't want displacement in the render to change the vector by warping.

KyL

Did you turn off the lights in the scene? It might sounds dumb, but it's easily missed when rendering out VDISP...