Can't Make Heightfield Work

Started by Aleksei, May 01, 2020, 06:08:09 am

Previous topic - Next topic

Aleksei

Hi!
Just starting from scratch and trying to apply the basic heightfield map (all the settings are on the screenshot below). And can't see the result. Can you tell me what I'm doing wrong?

Thanks in advance!
Multi-purpose Design Tool: • NORDSKILL •

KlausK

May 01, 2020, 10:28:02 am #1 Last Edit: May 01, 2020, 10:38:36 am by KlausK
Hi Aleksei,

the Height Range of your map ranges from 0 to 1 meter only.
You are simply too far away to see the displacement. I think I can spot the double line of the bounding box in your 3D view.

Go to your Heightfield Shader 01 - Displacement tab and raise the Height Multiplier for starters.
I guess it is still set to the default.

Hope that helps.

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

D.A. Bentley

May 01, 2020, 03:07:32 pm #2 Last Edit: May 01, 2020, 09:31:17 pm by D.A. Bentley
In addition to using the displacement multiplier to adjust vertical height often times you may need to adjust the horizontal size of the heightmap which you can do with a Heightfield resize node.

Aleksei

Great, thank you @KlausK & @D.A. Bentley !
It worked. I didn't expect these adjustments to appear in a separate node.

One more question: how can I adjust the relative Y position of my heightfield? I want to be able to move up and down in the global coordinate system (screenshot attached).

P.S. Sorry for the late reply. By some reason, I received neither email notification, nor website alerts about your messages. Though I subscribed to the topic.
Multi-purpose Design Tool: • NORDSKILL •

KlausK

May 02, 2020, 10:24:04 am #4 Last Edit: May 02, 2020, 10:31:29 am by KlausK
Something like this: >>see attached gif<< ?

You can do that with a "Heightfield - Adjust Vertical" node by redefining the Height Range.

Have you read the descriptions about the Heightfield Operators in the Wiki?
https://planetside.co.uk/wiki/index.php?title=Heightfield_Operators

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

D.A. Bentley

You might also want to experiment with the flatten surface first toggle in the heightfield shader.  By default it is on, but sometimes blending a heightfield into a fractal terrain is easier with flatten surface first turned off.
I have attached a Zip file which contains a tgd and heightfield to experiment with.  The heightfield is just a low resolution 8-bit tiff for testing.  In a real world situation you would want to use at least a 16-bit tiff for a heightfield/displacement map.  32-bit tiff and exr's also work.  The default Terragen scene includes a Simple Shape shader as well which can be used to create a level spot on your terrain, so try experimenting with its settings as well.

Hope that helps!

-Derek

Aleksei

Thanks again!
I tried the "Adjust Vertical" node, but at first, didn't understand how it works. I thought it's doing something different. Now, after the closer look, I got it.
Multi-purpose Design Tool: • NORDSKILL •