possible bug in default opacity

Started by Dune, March 09, 2021, 07:41:26 am

Previous topic - Next topic

Dune

If you set rendering of a tree to force displacement, the opacity of the leaves (by alpha mask) isn't working properly. They have black around the leaves visible.

Dune

Btw. Matt, would you like us/me to report (possible) bugs here, or in the alpha section, or at the project tracker?

WAS

I've wondered if this is best area too. I don't have access to any tracker or test forums though. 

I wonder if this has to do with the new recalculating of normal or darken bump at terminator features? May try playing with them. I remember something similar doing new bark awhile back on the Austrian Pines

Dune

I think it has to do with the latest change to get world opacity working. But I'd prefer the latter above the problem described. World opacity is a wonderful feature!

Valentina

June 19, 2021, 07:33:52 am #4 Last Edit: June 19, 2021, 07:47:07 am by Valentina
Hi, any solution to this problem?
with force displacement off I get nothing more then a bump map on the trunk, with smooth edges, but with the force displacement on, I can see a real displacement, with displ affecting correctly even the edges. But it messes up the leaves...
ps Path tracing seems also not to work well with force displacement
displ.jpg

Dune

Indeed, it has been put forward, but I guess Matt hasn't had time to tackle this yet.

WAS

Try splitting the object by it's foliage, and use the foliage with default rendering method. Since it doesn't really need real disp or could make them all jaggy.

Dune

There's also a way in Poseray to add displacement to (if present) parts of a tree. If the trunk/branches are different groups from foliage, you can make the foliage invisible, and import a displacement mask in another group tab, and it's subdivided and displaced by that mask. Then make foliage visible again, and save as.
If there are no groups, only materials you can go to groups and do 'materials to groups'.
If saved thus, you needn't use force displacement.

WAS

Quote from: Dune on June 20, 2021, 01:59:46 amThere's also a way in Poseray to add displacement to (if present) parts of a tree. If the trunk/branches are different groups from foliage, you can make the foliage invisible, and import a displacement mask in another group tab, and it's subdivided and displaced by that mask. Then make foliage visible again, and save as.
If there are no groups, only materials you can go to groups and do 'materials to groups'.
If saved thus, you needn't use force displacement.
I tried this and it doesn't seem to map to UV, and does its own thing. So say using the disp texture didn't align right. Least when I tried that.

Valentina

June 20, 2021, 05:51:58 am #9 Last Edit: June 20, 2021, 06:53:04 am by Valentina
I've tried duplicating the tree, and set leaves opacity to 0. But they still show up as black planes (with force displacement on), sort of 'primary visibility' to off, that usually works, seems not to work with force displacement.

Dune

So you have the tree twice, once with a 0 default shader for leaves and one with the same for trunk? Then the leaves-visible tree should not have force displacement, the leaves-invisible should, obviously. And still leaves as black planes? Then the bug is more persistent than I thought.

WAS

Force displacement doesn't work with opacity.

That was the point to splitting the object by foliage. Use force ray tracing ot default for foliage.

Valentina

June 28, 2021, 05:55:14 am #12 Last Edit: June 28, 2021, 05:59:56 am by Valentina
Here it is.. tell me if I'm doing something wrong and missing something..
ps: of course if i set render method to default on the Visible trunk, leaves don't show up, but then no displacement on the trunk 🤣
it's like 'force displacement' makes visible the planes  applying them a subtle displacement even if we edit the shader not to show up... it would be useful to enable/disable the visibility of the single parts instead of only tweaking with shaders.

Image_01.jpg
Image_02.jpg
Image_03.png

WAS

You really won't get best of both worlds without simply splitting the object into two; leaves and trunk. Not until opacity issue is fixed.

Third time I've said this. You won't defeat this error.

Valentina

the tree it's a tgo, as many of my objects.  I don't know how to split them, for Poseray doesn'l load tgo files. Can you tell me how to split a tgo file? or there is a way inside terragen?