Water problems

Started by DSDunbar, January 05, 2007, 03:24:14 pm

Previous topic - Next topic

DSDunbar

I'm attempting to render a real lake and surrounding topography w/o much success.  The surface of the lake is at an elevation of 524 m.  In the two attached screenshots all settings are identical except that in snap2 the water object (i.e., the lake) is enabled.  The grey area in both images is at a constant elevation of 524 m.  The red area is > 525 m.

Note that in both images the cursor is at nearly the same location, and yet in snap2 the Y-value is 549.6 m while in snap1 it is at the lake level of 524 m.  Also, I had to set the Water level to 640 to get water to show up in the lake, and as you can see it only appears in the bottom portion of snap2. 

What's going on?

Also - when I change the water level, the centre Y-value (525.083) changes with it, and maintains a constant difference of 115 m.  What's that about?

BTW, the terrain file is too large to include in this post.

old_blaggard

Interesting.  There are still some bugs to be worked out with water, but that mostly involves rendering, not camera position and preview.  I know this is a silly question to ask, but have you tried doing a full render of any of these?
http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

Matt

The difference between Y coordinates and water level can be explained by planet curvature:

http://forums.planetside.co.uk/index.php?topic=224.msg1774#msg1774

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Oshyan

How big is the lake/terrain? You can turn off curvature for the water object, I'm not sure if this might help. :D

- Oshyan