Obj Shadow Problem

Started by nvseal, March 26, 2008, 10:35:05 AM

Previous topic - Next topic

nvseal

I don't know if this bug has bee scene before but in my recent render the shadow of one object is surrounded by a black border. This only happened around one abject which makes me wonder if it is just a problem with the model. Does anybody know about this?

Arandil

Something to do with the (lack of a?) material?

cyphyr

Is the issue still there if you disable one of the suns?
Nice image
Richard
www.richardfraservfx.com
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
Ryzen 9 5950X @3.4Ghz, 16Gb (TG4 benchmark 4:28)

Oshyan

Are Soft Shadows enabled on one or both suns?

- Oshyan

nvseal

Soft shadows are enabled on one sun. I haven't done any test with the suns yet.

jo

Hi,

It does almost look a bit like one shadow is hard and the other is soft.

Regards,

Jo

rcallicotte

The leg does seem to be transparent.  Maybe it's the object handling.  Or not.
So this is Disney World.  Can we live here?

cyphyr

Did this issue ever get resolved (that is not just cropped out ;) )?
I have experienced an identical issue when using soft shadows and highly reflective surfaces.
Richard
www.richardfraservfx.com
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
Ryzen 9 5950X @3.4Ghz, 16Gb (TG4 benchmark 4:28)

Oshyan

We never received any additional diagnostic information so it's unclear (to us as well) whether it was resolved in this case. In your case does it happen whether Soft Shadows is enabled or not? Do you have multiple light sources? Does it go away if you *only* disable reflectivity, and does it appear related to the reflectivity of the shadow *casting* surface or the shadow *receiving* surface?

- Oshyan

cyphyr

hi there, I'm on my pda at the moment so I can't attach anything but these are the steps to reproduce the bug.
Import an obj.
Attach a reflective shader between the default shader and the multi shader.
Set soft shadows.
Leave all settings at default.
The effect is only visible with soft shadows enabled. Changing the quality settings in the render or the samples value in either the soft shadows or the reflective shader seems to have no effect. I'll try to post a tgd and image over the weekend.
cheers
Richard
www.richardfraservfx.com
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
Ryzen 9 5950X @3.4Ghz, 16Gb (TG4 benchmark 4:28)

cyphyr

Here are the files I promised.
Realy hope a solution can be found.
Richard
ps you'll need to either make your own object or use the one in the rar file below
www.richardfraservfx.com
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
Ryzen 9 5950X @3.4Ghz, 16Gb (TG4 benchmark 4:28)

j meyer

Hi Richard,
have you seen this thread http://forums.planetside.co.uk/index.php?topic=3087.0
already? Seems to be the same issue.I had that too when i was testing things for my
olmec head pic btw.
         

Oshyan

Thanks Richard. We'll look into it.

- Oshyan

cyphyr

Just made a quick test using Terragens own internal sphere object and this dose not seem to be effected by the bug.
Richard
www.richardfraservfx.com
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
Ryzen 9 5950X @3.4Ghz, 16Gb (TG4 benchmark 4:28)

Matt

#14
I've just fixed this today. Shadows of reflective objects should also be quicker to calculate. You'll see this fix in the next update.

Matt
Just because milk is white doesn't mean that clouds are made of milk.