My first weird error with TP5...

Started by dandelO, October 06, 2008, 08:14:21 pm

Previous topic - Next topic

dandelO

October 06, 2008, 08:14:21 pm Last Edit: October 06, 2008, 08:19:12 pm by dandelO
I repeatedly get this error when opening a project I was working on. The error doesn't display correctly in the errors field-box either(a bit like Andy Welders problem a few days ago).

The error appears to say: Parse error at line 303: Unclosed token

This is the .tgd if it's required(minus 2 image maps, 1 object and 1 terrain file, if they're needed I'll email them, they don't seem to be part of the problem though).

I have a save file of this scene which works fine, I don't need any quick diagnosis done as this error happened when I was editing my own version to add to my public library, I think all I did was remove some rock shaders and then assigned the base colours to the surface of the plane node (which is the terrain) instead of the original rock colouring I used in my scene. Instant crash and now this version of the tgd won't open at all.

Like I say, no need to rush to fix it. I'm just reporting the error. I've never seen it before and wondered if anyone else had.

The .tgd opened in a text editor ends at the 'terrain' group. Everything that should be after it has just vanished.

jo

Hi,

The error happens because somehow the file has got truncated. No idea why that might happen, although I guess it was down to the crash, but I recall someone else had this problem a little while ago. I assume it crashed while you were saving?

Regards,

Jo

dandelO

Yes, the file crashed upon save. The .bak file was OK though as the crashed save didn't make it to the point where that would be created and that means I don't even have to go as far back as my original .tgd to remedy things. I really have no idea why it's happened, the nodes in the .bak appear to be the same as when it did crash whilst saving, so there's nothing wrong with my layout, apparently.

Cheers, Jo.