ctrl-C and ctrl-V

Started by rcallicotte, April 14, 2009, 06:29:20 pm

Previous topic - Next topic

rcallicotte

Mine still has problems...

I have other windows open - This one, for example.   ::)  I'm not doing anything complex, when I see this problem.
So this is Disney World.  Can we live here?

Oshyan

He means other TG2 windows, like separate node windows, additional 3D preview windows, etc.

- Oshyan

rcallicotte

Oh.  Right.  I'll check tonight and get back with you.
So this is Disney World.  Can we live here?

j meyer

Hi,
for me ctrl+c and ctrl+v does not work in the node view of the main
window copying nodes,no other windows open.
Vista x32.

rcallicotte

I had the properties window open for <whatever>.  In this mode, this is still a problem.

I'll try to find a way when it is not a problem and re-post.




Quote from: Oshyan on April 15, 2009, 11:13:50 pm
He means other TG2 windows, like separate node windows, additional 3D preview windows, etc.

- Oshyan
So this is Disney World.  Can we live here?

mr-miley

Same here for me. As Calico said, I used to copy the value of an "X" (or y or Z) value from the coords of one object using Ctrl C and paste them into the "X" (or y or Z) value using Ctrl V all the time. Since the latest update I cant do that. From memory I can right click in the "cell" and select copy and the right click and select paste, just not do it with keyboard shortcuts. I know this is superceeded by the copy coords button which is superb, but when you just want to use one coord it is a bit of a pain, especially if you are used to the keyboard way. By the way, excellent new release, love all the extra bits  ;D
I love the smell of caffine in the morning

Oshyan

I think the key here is the single coordinate thing, and may be related to the copy/paste functionality we added. We'll take a look at it.

- Oshyan

neuspadrin

There may be something triggering it after some event, as I know its happened to me before, but when i open up tg2 and just attempt to copy and paste right from a fresh scene, it works, so i've been unable to replicate, and i havn't used tg2 a ton since release due to school work.

commorancy

Quote from: jo on April 15, 2009, 08:53:29 pm
Hi,

For those having problems with this, do you have any other TG2 windows aside from the main one open when you're having trouble?

Regards,

Jo


No, no other TG2 windows open.  This is definitely a problem.  These keys are definitely disabled in 2.0.2.1.  I just posted a thread before I found this one.  They don't work for me and haven't since I installed 2.0.2.1.  When I select any object that has the ability to copy/paste, the hot keys do not work.  Even ctrl-z doesn't work (undo).  I haven't had them work since I've installed this version.  Perhaps it has something to do with the addition of ctrl-r ?

Thanks.


jo

Hi,

Someone posted a test for this problem on another thread, which I can also reproduce. I'll get started on fixing it.

Regards,

Jo

rcallicotte

Thanks Jo.  At least I can still use the mouse to copy and paste...so...thanks.
So this is Disney World.  Can we live here?