A Bug Maybe?

Started by Thelby, July 27, 2009, 10:37:32 pm

Previous topic - Next topic

Thelby

I was showing someone how the bump (Displacement) worked in TG2 and discovered a shadow that popped up when using a negative value. However it does not start until the 1 crosses the decimal point on the left. Example: Default value displacement is 0.01, make it negative -0.01 and is OK. It is OK at -.1 also, but make it -1 and the problem starts.
The first image is Default Displacement 0.01.
The second is with -1 Displacement.

Matt

July 27, 2009, 10:58:08 pm #1 Last Edit: July 27, 2009, 11:00:26 pm by Matt
The shadow tracer doesn't recognise displacements on objects (only on planets, spheres and planes). Displacement should be kept to small values and should always be positive to prevent the surface from sinking into regions of shadow.

(Sometimes a small negative displacement is OK, but it's safer to avoid it completely.)

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Thelby

Will that change in the future at some point? I mean having displacement on an object, say a house is essential to the realism of the scene. Just asking!!!

Matt

Yes, some day :)

You can already use displacement, and it affects the shading of the surface, it's just that the shadows don't see it.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Thelby

So instead of using a bump map that needed a negative value it would be better to invert it before using it to avoid this altogether.

Matt

You can use a negative displacement amount if you compensate with a positive displacement offset. If you need a displacement of -1, set the displacement offset to +1.

Matt
Just because milk is white doesn't mean that clouds are made of milk.