Render Crash

Started by jbashyam, March 28, 2014, 07:04:58 pm

Previous topic - Next topic

jbashyam

Hi there,

I'm having a lot of trouble with rendering in Terragen 3. Every time I try to render anything above 1280x720, after a few minutes either my graphics card crashes or my system runs out of memory and crashes. Don't know why this is happening as I have a pretty good machine with 32gb of ram and a very fast video card as well as processor. It's almost as if Terragen isn't putting a cutoff limit as to how much power it uses. Any help fixing this would be much appreciated, as I have a project deadline in a few weeks and need to get this started asap.

Thanks,
John

yossam

Sounds like overheating to me.  :(

jbashyam

I've been monitoring the temperatures, and they seem to be fine. I also have a liquid cooler on my CPU.

yossam

What are your system specs and is this repeatable..............in other words does it happen every time you try to render larger than 1280x720?

Kadri


If you have overclocked your machine the first thing i would do is testing it without overclocking and see what's happening

jbashyam

It is overclocked, I'll try without.

System specs:

Core i7 3960x
32gb 2133mhz ram
Evga gtx 780 super clocked
Asus rampage extreme mobo
Corsair h100i cooler
2x 240gb ssd in raid 0
3x 2tb hdd
1x 4tb hdd

yossam

Sometimes the overclocked video card can cause issues also.

jbashyam

Hmm okay, I think it's overclocked by default though and not much I can do about it.

Oshyan

Quote from: jbashyam on March 28, 2014, 07:04:58 pm
It's almost as if Terragen isn't putting a cutoff limit as to how much power it uses.


No, it certainly isn't. But why should it? It's up to the Operating System and hardware (e.g. BIOS, thermal sensors) to manage application demands and assign resources accordingly. Terragen just takes all that it's given and runs with it. :D You can reduce the number of cores TG will use for rendering by setting it in the Preferences, but ultimately if it's crashing due to resource demand it's an issue with the system, not with the software.

Do you use any other demanding 3D rendering applications? Games are not necessarily the same because they stress the GPU much more than the CPU in most cases. If there is a CPU heat issue, or perhaps a memory issue, Terragen is likely to make it show up due to the demands it makes on the system basically.

- Oshyan

jbashyam

Thanks for the reply. Yes I am able to handle very intense render loads in maya, nuke, and after effects with no problem. It's only Terragen that seems to be causing issues. I'm not sure why the gpu would crash as there is no reason it would use it to render. As far as the memory overload, shouldn't windows regulate the amount of ram Terragen can use?

Oshyan

Windows does regulate the amount of memory TG can use, but if TG requests memory it requires for rendering and is denied, it can sometimes crash. So that may be what's happening, although it sounds like you should have plenty of memory for most renders.

So perhaps it's more GPU-related. When you say it "runs out of memory", what symptoms of that are you seeing? If it's the GPU, it would not be a power issue, rather a potential driver function compatibility issue, specifically with OpenGL functionality. To test this (partly) you can try starting Terragen with the flags -no3dpreview and -nonetworkview and then try the same render that usually crashes. If it still crashes, try to get as much info about the crash as possible and send it to support AT planetside.co.uk along with the .TGD.

- Oshyan

jbashyam

I've seen one of two things happen during rendering. The first issue was that the system blue screened and dumped memory to disk when rendering an animation at 1080 res. The second time I dropped the res to 720 and not even after rendering one frame it said graphics driver has stopped working, Terragen has crashed. How do I start teerragen with those flags?

Oshyan

Interesting. So, on Windows 7 (or basically Vista and newer), an application should not be able to bring down the entire system unless there is a problem in some driver or hardware issue somewhere. So Terragen is triggering something, but the system shouldn't be going down entirely unless there's something else wrong. The fact that you had a graphics driver crash later suggests it may be related to that, but hard to say.

To start Terragen with flags you need to edit the shortcut that you use. Right-click your shortcut and go to properties, then edit the "target" and put the flags *after* the ending " quote that should be ending in "tgd.exe"

However, given that the crash happens during rendering, it's questionable whether this will help as Terragen only uses OpenGL (and the graphics card in general) for the user interface and 3D preview in particular. Those flags turn off the 3D preview and node network, the most heavy OpenGL users in TG. But they're not really used during rendering so it would be odd to have a graphics driver related crash from rendering. Not impossible, but odd.

- Oshyan

jbashyam

Yeah it is very strange, I think it is an issue to do with my system though. Are there any render settings that I should be concerned about that could possibly optimize it a bit better?

Oshyan

If a crash is happening, it's probably not due to render settings on a system like yours.  Unless you're doing something really crazy that uses tons and tons of memory, and then A: your render would be really slow/take a long time, and B: even if it crashed, it shouldn't crash in the way that affects the rest of the system. The only crashes that would occur from settings would normally be memory-related, although there are a few intermittent bugs that can cause crashes in other circumstances, but again those will only take down Terragen, not your system or graphics driver.

If you want to post a .TGD that shows the problem, or send it to the support email, that might help diagnose further...

- Oshyan