Classic Erosion plugin

Started by Daniil, November 03, 2017, 05:14:19 am

Previous topic - Next topic

Dune

You're elaborate, Jordan. I am always a bit careful with a first time poster, as it may be a spammer coming in quietly ;)
We'll see...

WAS

June 06, 2021, 03:00:27 am #226 Last Edit: June 06, 2021, 01:44:02 pm by WAS
Quote from: Dune on June 06, 2021, 01:31:38 amYou're elaborate, Jordan. I am always a bit careful with a first time poster, as it may be a spammer coming in quietly ;)
We'll see...

I did it to refer to, as this has been asked too many times as is.

Also good to just provide the best support possible, every time.

Alvin R.F.

June 14, 2021, 08:26:58 pm #227 Last Edit: June 14, 2021, 08:54:44 pm by Alvin R.F.
Hi,

Thank you for your response. I can assure you, I am no spammer but do appreciate the clarification. I followed the instructions you have provided and it worked!

Thanks

Alvin

Dune

Glad you're not another spammer! Welcome!

WAS

I know you aren't really looking to update this plugin in the foreseeable future, @blinkfrog but one little thing that would be nice is when a shader is eroding, it said the shaders name in the prompt window. I am now using a LOT of erosion shaders and it would be beneficial to know where I am in progress, which also may indicate bad settings and exaggerated processing times.

Daniil

August 21, 2021, 01:42:31 pm #230 Last Edit: August 21, 2021, 01:46:54 pm by blinkfrog
Classic Erosion v 1.1.6

Changes:

- Improved stability (fixed freezes, crashes and memory leaks);
- Improved portability (it isn't necessarily to run installer; simple copying of dkclassicerosion.tgp to "\plugins\" subfolder of Terragen is enough; previously this worked too, but there were problems with registration);
- Improved performance (a little);
- Progress window (and log) now displays the name of erosion node. Useful when you have multiple nodes, named differently;
- Progress and registration window sizes are corrected.


Daniil

WAS

Quote from: blinkfrog on August 21, 2021, 01:42:31 pm- Progress window (and log) now displays the name of erosion node. Useful when you have multiple nodes, named differently;
Awesome! Thanks for the consideration, Daniil.

WAS

I'm not sure if this is just me, but I notice that the "improved performance" seems a little slower for me doing a relatively small 4K erosion of just a 2k meter area. In addition, I can't run music at all while this operation is going on, youtube and the computer get choppy (music glitchy, pages scrolling glitching, text taking awhile to catch up while I write this).

Not to big of a deal work wise as I can just plug in my phone for music, but I do wonder if it's using too much of the CPU, and at the same time I wonder if the plugin can follow the settings and CPU thread limit (like if I have 10 of 12 set, it uses 10 threads).

Also wonder if anyone else notices it's a little heavier on their CPU? Just me? I know my CPU is really barely mid-range these days...

Dune

I can't really tell, but well, I'm on my new machine and it takes very little time. Can't compare that.

Lithium

I'm having some troubles downloading this plugin, and downloading plugins in general, by any case, how should I install it?

Daniil

Quote from: Lithium on August 28, 2021, 01:33:46 amI'm having some troubles downloading this plugin, and downloading plugins in general, by any case, how should I install it?
Hello, could you please elaborate what problems do you have?

You need to download the latest version of installer here: https://daniilkamperov.com/downloads/#classic-erosion
Then you need to launch the installer and follow all the steps of installation procedure. After the installer completes installation, you can launch Terragen and use the plugin, which adds Classic Erosion node in the Displacement group of shaders.

Daniil

Dune

I think it's a spammer, Daniil, but I'm not sure. First post, immediately going to your (this) plugin, mmmm.

icarus51

I don't manage to install Classic Erosion 1.1.6. I start the installer (Repair) and then i start Terragen but i find the old file 1.1.5. In the plugins folder i find this old version. In the zip file i see only the installer, no file dkclassicerosion.tgp. The old version works but the new is missing. New version is signalled in the plugin window in Terragen like update. :(

WAS

The installer may not have privileges to overwrite files, or something, so maybe try deleting the original plugin from within Terragen's plugin folder (backing it up to the desktop or something before deleting it). Then try to run the installer again.

icarus51

Hi Jordan,

I've made this but nothing.
Deleted the plugin after backup and played the installer.
Closed and Rebooted  the PC. Nothing  at all but Terragen starts without the old plugin so i have to copy the old pluging in the plugin folder to find again it in TG, otherwise i cannot play not even the old version that i've registered. It's a mistery that i have to investigate later.
Thanks for your reply.