multiple glass shaders

Started by gasbutan, January 26, 2020, 02:57:47 pm

Previous topic - Next topic

gasbutan

Hi everybody,

I have a problem with multiple objects having a glass shader.
In the example below I made a scene with 3 glass plates placed one behind the other.
The first render is done with standard renderer, the second with ray tracer.
In both cases ray detail multiplier is set to 1.0
For the ray tracer I used max paths per sample of 100.
The results are not really satisfactory.
Any ideas how to improve it ?


thx

test031_standard.jpg      test031_raytraced.jpg

Hannes

Set Render/Advanced/Subdiv Settings/Ray detail multiplier to 1 and
Render/Advanced/Max Ray depth in PT to higher than 5, until the glass isn't black anymore. Maybe this doesn't work in the raytracer, but it should in the path tracer.

gasbutan

Thx Hannes. 
I have to correct myself: the second is made using the path tracer. Max ray depth is already at 100.
Doesn't work  :(

Oshyan

Is it "Max Ray Depth in PT" (on Advanced tab) that is 100, or *Max Paths Per Sample* (on Quality tab)?

- Oshyan

gasbutan

Quote from: Oshyan on January 26, 2020, 08:16:54 pmIs it "Max Ray Depth in PT" (on Advanced tab) that is 100, or *Max Paths Per Sample* (on Quality tab)?

- Oshyan
hmmm - obviously i got that mixed up, thanks for the advice!

gasbutan

Much better, but still not perfect.
Max Ray Depth in PT is 13, it seems to be the maximum possible.

test031_pt.jpg

Hannes

The black glass is gone, but did you set Render/Advanced/Subdiv Settings/Ray detail multiplier to 1? Otherwise the geometry behind the glass will be low res.

gasbutan

Quote from: Hannes on January 27, 2020, 05:55:17 pmThe black glass is gone, but did you set Render/Advanced/Subdiv Settings/Ray detail multiplier to 1? Otherwise the geometry behind the glass will be low res.
Yes, ray detail multiplier is 1.

Tangled-Universe

The left side of the foreground element is not covering the second element and directly showing the terrain through this one single element.
If you observe the refraction the terrain detail is lower and that's why I agree with Hannes's question regarding the ray detail multiplier.
If the ray detail multiplier is really set at 1 then this a bug.

Can you doublecheck or post the tgd otherwise?

KlausK

Hi, Not trying too hijack this thread but I had a go at this kind of setup as well.
Comment away, especially if there is anything noteworthy about the setup.
I find the results rather...I don`t really know wht to think.

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

gasbutan

here is the tgd for my scene...

thx for the support

test031d.tgd

Hannes

Confirmed. Gasbutan, your settings seem to be correct. I also tried Klaus' file, and even reduced the IOR to 1.1 for testing. With the path tracer the detail of the terrain behind the glass objects is completely lost.
And there are still black glass objects even with the maximum Max ray depth.

KlausK

Thanks, Hannes. Perhaps Matt or Oshyan should have a look at this then.

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

gasbutan

Thank you Hannes and Klaus for your confirmation.
Obviously a bug ?

WAS

Do you have 360 optimal crop region set? I don't see it mentioned and I notice some background reflection which would be controlled here i think (in KlausK's version). Perhaps it also makes a difference at multiple depths of glass refraction.