reflection errors

Started by chris_x422, December 18, 2008, 09:31:44 am

Previous topic - Next topic

chris_x422

December 18, 2008, 09:31:44 am Last Edit: December 18, 2008, 09:37:08 am by chris_422
Hi,

I have an urgent situation, already past deadline trying to find a solution to this.

Basicaly, I have a canyon with very high sides (8km) reflecting back into a river at the bottom.
Whenever I render the sequence, the geometry flickers in the reflection.

I've stripped the scene down to basic components, no gi, no atmos, etc just geom, reflections and shadows.
The base geom, is a heightfield with only fractal detail added on the shader, no other displacements or shaders.

It looks to me from the image that the geometry off camera is not being subdivided.

Hope someone can shed some light on this.

Thanks

Chris

Matt

Hi Chris,

Your guess is correct. For ray-tracing purposes the surfaces outside the viewing frustum are subdivided to a much lower level because in a lot of situations this is the only way to ray trace those surfaces in a reasonable amount of time. I can try to get you a build that subdivides to a much higher level but it will take me a few hours and I can't be sure how well it will work.

Something I'd like you to check: What is "detail blending" set to in the render settings ("Extra" tab)? If you set that to 1 it should interpolate between LoD levels, in both the reflections and the visible geometry. Unfortunately I am not exactly sure whether this works on the low-detail geometry outside the frustum.

You may be able to hide the problem if you use rougher water settings (to break up the visible polygons). This should work better if the detail blending works on those polygons. Unfortunately all of these solutions are likely to increase render times.

If none of this works, you may have to resort to rendering the water as a separate pass with the terrain as a black holdout. You'd be reflecting black terrain.

Let me know if any of this helps and what you'd like me to do.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

neon22

How about pulling back and rendering in a larger viewport/image. The image size would be a lot bigger -  so crop it so that the render time does not go up...

Then you will have to crop all resulting images (assuming its an animation sequence)

Matt

December 18, 2008, 11:03:13 pm #3 Last Edit: December 18, 2008, 11:05:36 pm by Matt
The LoD reduction applies to geometry outside of the rendered crop region, not just the overall image. So you would have to render the oversized image and crop afterwards. Defining the crop inside TG would just bring you back to the original problem.

Rendering the oversize image will obviously take longer but it may turn out to be quicker than the "fix" I am working on. And it's more likely to work, too. We shall see.

What I may do is expand the frustum that's used to decide where to start reducing LoD. Padding the ray-tracing frustum basically. Then you could control that.

Matt
Just because milk is white doesn't mean that clouds are made of milk.