Terrain and shadows changing during animation

Started by seanQuixote, March 30, 2010, 06:05:43 pm

Previous topic - Next topic

Oshyan

Strange, I am not getting that same result. What frame is that? Is it the same settings I posted in the TGD above, or changed?

- Oshyan

MKE

March 17, 2011, 05:00:39 am #16 Last Edit: March 17, 2011, 05:14:04 am by MKE
Quote from: Oshyan on March 17, 2011, 01:33:56 am
Strange, I am not getting that same result. What frame is that? Is it the same settings I posted in the TGD above, or changed?

- Oshyan


Hmmm, I didn't change the settings. The only thing that is different is that I used the camera for the left eye (3D rendering). One thing that could create a difference: You used version 2.3.15.0 for your tests, while I still run 2.2.23.1 here. Maybe I should get the newest version first?

Edit: It seems I have the newest version available... Could you check if the results are the same if you use 2.2.23.1 instead of 2.3.15.0? If this makes the difference I'd be very happy if you could release 2.3.15.0 asap.

Kind regards,
Martin


MKE

Hi Oshyan,

I did some more tests during the last days. I raised the sun to see if the shadow problem disappears. Unfortunately it does not. I went up to 25° over the horizon and the shadows still retreat if you approach. Of course the effect is less because the shadows are not that long any more but it's still visible and annoying. I think that this is a bug in the software which should be fixed as soon as possible. Since the raised sun didn't solve the problem but destroyed the beauty of the DEM with long shadows I set the sun back to 10° above the horizon as it was before.

I wonder why I don't have any problems any more with the little shadows in bright sunlight that should not exist and disappeared by approaching in my first animation trial. This problem is not existent any more. Did you change some hidden values in the tgd-file you uploaded in the forum? If that's the case: Good work. These settings should be also used for the initial settings in a new tgd-file.

In some other tests I saw that the higher values for global illumination slow down the rendering very much without increasing the quality adequately. Instead I increased the picture size to the full resolution (2048 x 1080) by reduced rendering quality settings. This still looks better and is faster than my old and your proposed settings. Maybe it will help other users later on with their animations, so here are my actual settings:

Quality:
Detail = 1 (absolute minimum for decent images)
Anti-Aliasing = 2
Ray trace objects
Ray trace atmosphere
GI relative detail = 1
GI sample quality = 1
GI blur radius = 20
Supersample prepass

Extra:
Pixel filter: Narrow cubic
Anti-aliasing bloom
Detail blending = 1
Displacement filter = 1
Microvertex jittering
(Detail jittering off)
(Lock subdiv to frame off)
Do ray traced shadows
Ray trace everything (which made the rendering much faster)

Advanced:
Minimum threads = 2
Maximum threads = 8
Size of subdiv cache in MB = 800
Ray detail region: Detail in camera
Ray detail region padding = 3
GI prepass padding = 0


Kind regards,
Martin

Matt

March 26, 2011, 02:14:39 am #18 Last Edit: March 26, 2011, 02:18:20 am by Matt
Oshyan probably created a "render subdiv settings" node in the render node's internal network. With that node he probably changed a couple of switches and increased the "ray detail multiplier". You would need to keep that node in order to match Oshyan's results.

Unfortunately, I don't think 2.2.23.1 supports all of those settings. You might have seen some warnings when you loaded or copied his render node. Without the "ray detail multiplier" your renders would have lost a lot of detail when you enabled "ray trace everything", which is why you needed to put the master detail up to 1.
Just because milk is white doesn't mean that clouds are made of milk.

Matt

There is nothing you can do to completely prevent popping shadows if the shadows are coming from behind the camera (at more than 90 degrees from the camera viewing direction in 3D space). This is something we need to fix on our end.
Just because milk is white doesn't mean that clouds are made of milk.

MKE

Quote from: Matt on March 26, 2011, 02:14:39 am
Oshyan probably created a "render subdiv settings" node in the render node's internal network. With that node he probably changed a couple of switches and increased the "ray detail multiplier". You would need to keep that node in order to match Oshyan's results.

Unfortunately, I don't think 2.2.23.1 supports all of those settings. You might have seen some warnings when you loaded or copied his render node. Without the "ray detail multiplier" your renders would have lost a lot of detail when you enabled "ray trace everything", which is why you needed to put the master detail up to 1.


Hi Matt,

yes, there were some warnings. So I hope on the new version of TG2 for the next trial. I will download the new version when the actual animation rendering is finished. It's kind of an iterative process to improve the animation and each time I learn something new or the software has improved... ;-)

Kind regards,
Martin

PabloMack

April 24, 2011, 05:03:59 pm #21 Last Edit: April 24, 2011, 05:32:54 pm by PabloMack
One thing that I have realized is that, as fractal geometry detail is determined by its distance from the camera, geometry flicker is usually not bad when, say, a mountain peak is far away from the camera. However, the sun can cast a shadow of a distant peak onto some terrain that is very close to the camera. In such cases, the geometry flicker's shadow can be very close to the camera. Magnified this way it can look very bad.

I suspect that all terrain and most shadow flicker is due to TG2 creating geometries from scratch on every frame based on where the camera is during that frame. This obviously stems from TG2's roots in still imagery as animation was an add-on at some later date.

If TG2 had a little box that you could check that forced all fractal geometry to be created up front based on its closest distance to the camera's path (i.e. always used the distance to the camera at its nearest point from any one point in the geometry) then all geometry flicker and most shadow flicker (that due to geometry and not due to variation in light sampling) could be eliminated. In fact, by generating geometry only once (instead of for every frame), the whole process could, perhaps, be sped up. Granted, there would be excess geometry not needed by every frame. But the alternative is to have to generate excess geometry for the whole frame just to eliminate bits of flicker here and there as it is now.

Matt

Quote from: PabloMack on April 24, 2011, 05:03:59 pm
One thing that I have realized is that, as fractal geometry detail is determined by its distance from the camera, geometry flicker is usually not bad when, say, a mountain peak is far away from the camera. However, the sun can cast a shadow of a distant peak onto some terrain that is very close to the camera. In such cases, the geometry flicker's shadow can be very close to the camera. Magnified this way it can look very bad.

I suspect that all terrain and most shadow flicker is due to TG2 creating geometries from scratch on every frame based on where the camera is during that frame.


Yes that's true.

Quote
If TG2 had a little box that you could check that forced all fractal geometry to be created up front based on its closest distance to the camera's path (i.e. always used the distance to the camera at its nearest point from any one point in the geometry) then all geometry flicker and most shadow flicker (that due to geometry and not due to variation in light sampling) could be eliminated. In fact, by generating geometry only once (instead of for every frame), the whole process could, perhaps, be sped up. Granted, there would be excess geometry not needed by every frame. But the alternative is to have to generate excess geometry for the whole frame just to eliminate bits of flicker here and there as it is now.


The needed geometry would be huge. In many cases I expect it would be unmanageable.

I have a solution to the shadow flickering which we will release with Terragen 2.4 with Animation. Actually it's a combination of various recent improvements which haven't been made into official settings yet, combined with a new ray detail stabilisation feature which is working very well. This solves problems with small micropolygon shadows changing from frame to frame. There is still the second problem of shadows cast from terrain behind outside the camera view (which ray detail padding helps with but doesn't work for terrain behind the camera). We'll also provide a solution to that in v2.4.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

MKE

Quote from: Matt on April 24, 2011, 07:19:37 pm
I have a solution to the shadow flickering which we will release with Terragen 2.4 with Animation. .... There is still the second problem of shadows cast from terrain behind outside the camera view .... We'll also provide a solution to that in v2.4.



Hi Matt,

this is very good to hear and absolutely neccessary to get high quality animations. During the last weeks I played around with differend parameter values (and I got a faster computer... ;-) so the processing time for good quality animation frame is down to 8 minutes now.

There are still some errors in the animation. Two error sources are hopefully gone with TG 2.4, for a solution of the third I hope on the expertise of you and the forum.

- there are still receding shadows as you approach them. Other than in my previous animation this time the sun is at a 90° to the camera look angle (and the flight path). The camera is looking towards north and the sun is 10° over the horizon directly in the east. See attached subsets of image 855 and 856.

- The shadow flickering is quite annoying, although I increased the GI values. I really hope for TG 2.4.
See attached subsets of images 1142 and 1143.

- From time to time it looks like the indirect illumination of the atmosphere is switched of. Then after some images, the normal illumination comes back. Do you know about this bug? Do you have any idea how to deal with that? See attached subsets of the images 1537 and 1538.

The parameter values I use now (tgd-file attached):

Quality:
Detail = 1
Anti-Aliasing = 4
Ray trace objects
Ray trace atmosphere
GI relative detail = 2
GI sample quality = 2
GI blur radius = 200
Supersample prepass

Extra:
Pixel filter: Narrow cubic
Anti-aliasing bloom
Detail blending = 3
Displacement filter = 0
Microvertex jittering
(Detail jittering off)
(Lock subdiv to frame off)
Do ray traced shadows
Ray trace everything

Advanced:
Ray detail region: Detail in camera
Ray detail region padding = 3
GI prepass padding = 0



By the way: the forum editor is horrible. I had to type blind because while typing the visible window sticks to the uppermost text. And when sending the post there came the error message that tif-images are not allowed and all my text was lost. So now I type everything again in my own editor and copy it into the forum...

Kind regards,
Martin[/quote]

dandelO

July 28, 2011, 01:14:35 pm #24 Last Edit: July 28, 2011, 01:19:49 pm by dandelO
I don't know if anyone's posted this to this thread yet, just read the last reply.

To get better quality edges and shadows of planet geometry, you can(if you have the render subdivision settings node enabled in the renderer), check the box 'fully adaptive'. The difference between the following two quick renders is only that single setting...

Detail=0.75(detail blending=0)
Fully adaptive=unchecked(default):
[attachimg=#]

Fully adaptive=checked:
[attachimg=#]

Checking fully adaptive makes(according only to my personal tests, I've no actual confirmation of that or that this is what the setting does) cast shadows and displacement edges render more correctly. I've tried this with animated parameters too. With 'FA' checked, the results of shadows are a whole lot better(at the expense of some render time!).

When the 'AA adaptive sampling' methods were introduced, I noticed the shadows became more raggedy at default settings, I know there was always a shadow popping problem before this but it was definitely exacerbated, I think, with the introduction of some of these settings a few releases ago.

The 'ray detail multiplier' is set at default=0.25 for both of the above, btw.

Henry Blewer

I can't find this shadow setting you are talking about. Where is it?
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

MKE

July 29, 2011, 05:07:05 am #26 Last Edit: July 29, 2011, 05:27:14 am by MKE
Quote from: dandelO on July 28, 2011, 01:14:35 pm
... if you have the render subdivision settings node enabled in the renderer...


The improvement in your is really impressive. Thanks for showing us the difference.

Well, I have this subdiv setting node for one renderer (@njeneb: Node Network tab, then on the left side you see a list of nodes where the renderers have a "+" in front of them. If you click on that, some additional settings become visible). I have no idea why only one renderer has this node and how I could manage to have it also at the renderer I use for the animations. In the node palette (View->Node Palette) I find no render nodes to chose from. Right mouse click? Nothing... No possibility to "copy" or "create" a node. Am I to stupid to use TG2?

How can I copy or create a new render subdivision node for the renderer I actually use?

Edit: Here two new images showing the indirect light problem. Nothing has been changed in the tgd-file except the camera position...

Kind regards,
Martin

Henry Blewer

http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

dandelO

Henry; To enable these settings visit the internal network of your render node and just copy/paste(ctrl+c/ctrl+v) the following clipfile text...

<terragen_clip>
  <render_subdiv_settings>
  </render_subdiv_settings>
</terragen_clip>

Now you have access to that setting, among others. You might want to save your default project with this node enabled so you don't need to repeat this process each time you need it. :)

Henry Blewer

Thanks Martin. I wonder how many other things are hidden?
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T